Main Site Documentation

Hel Reviving my Panda


#1

Hi guys!

I finally managed to kill my beloved Panda! I had a wire to one of the digital pins and I dropped the wire and it touched something else, I don’t know what it was, but the only thing I heard was the sound of a disconnecting USB device on my PC. I reconected the Panda, the light goes on very dim, but no sound on my PC that a device gets connected and nothing in TerraTerm or MFDeploy or whatsoever.

I considered my Panda USBBizi Chip lost somehow and ordered a new NXP chip, so not from GHI. Without thinking that a NXP chip would be empty!! So now I have a Panda with a new Empty chip from NXP and I want to get it to life somehow, I have tried to get the open source firmware on it, but the Panda still isn’t being recognized as a USB device, what else could cause the Panda to not be recognized? I changed the LDO already and the transistor! What else can be damaged the diodes?

Thanks guys!


#2

Do you measure 5V and 3V3 ? (Can you measure with oscilloscope to check the ripple voltage)

Is it possible the MCP130 holds the device in reset?


#3

You should measure 3V3 on the reset pin.

Maybe you’ll need to program GHI firmware through the JTAG connector.


#4

hi Wouter! Thanks for the answer! unfortunatly I do not have a scope, always wanted to buy one, but don’t know how to use it :slight_smile:

Correct me if I’m wrong, but the Panda does not have a MCP130, or am I mistaken? I will check the voltage on the reset pin, get back on that.


#5

There is a MCP130 on the Panda schematics


#6

I know, but I don’t think it is populated on the boards itself, I don’t have the schematic here right now, but if MCP130 is IC2 then its empty on my Panda’s.

I have measured the voltage levels on the row headers of the Panda. 5V gives 5V 3.3V is 3.3V and the reset pin is 3.3V


#7

On a picture of the Panda I see that IC2 (MCP130) is not included. So that will not be the problem.

You should get some firmware on it. Don’t you need a JTAG programmer for that? Also don’t know if you can find the original GHI firmware.


#8

I think it can be done through RS232. I’ve got it to respond now with “Synchronised” so I got a sign of life from the NXP bootloader… now I have to see if I can get the opensource firmware on it :slight_smile:


#9

Hmm strange… I follow the Beginner Porting E-book and somewhere it says to compile the firmware I have to type: MSBUILD.EXE /t:build /p:flavor=release;memory=flash

But then it says that MSBUILD.exe cannot be found!? I searched my C drive for MSBUILD.exe and found it somewhere in the windows folder… I copied it to the PK folder and ran the same command… now I see a lot more, but it ends with this error:

E:\MicroFrameworkPK_v4_1\tools\targets\Microsoft.SPOT.System.Targets(225,5): err
or MSB4036: The "RemoveDir" task was not found. Check the following: 1.) The nam
e of the task in the project file is the same as the name of the task class. 2.)
 The task class is "public" and implements the Microsoft.Build.Framework.ITask i
nterface. 3.) The task is correctly declared with <UsingTask> in the project fil
e, or in the *.tasks files located in the "E:\MicroFrameworkPK_v4_1\Solutions\US
Bizi_OpenSource\TinyCLR" directory.
    23 Warning(s)
    1 Error(s)

Time Elapsed 00:00:00.00

#10

Ok solved that now… I have compiled the TinyBooter now…

Problem now is how do I get it onto the Panda… I have tried with Flash Magic… and it flashed succesfully, but Windows still does not recognizes it as a USB device :frowning:


#11

Have you tried another USB port on your computer?


#12

Yep, I even tried another PC, no go… I can flash stuff to it with Flash Magic, but no USB (Virtual COM Port) gets detected on my PC.


#13

USBizi on this website costs about the same as raw NXP chip… basically you get our firmware for free :slight_smile: So why not just use USBizi and save yourself all the extra work?


#14

I know, I know :-[ I will next time, but I could get a few of these chips from a friend for very little, so… and I like to try if I can get it to work like this.

Do you have any idea why USB is not responding GUS? does it need to respond even if you put an empty NXP chip on it?


#15

It will probably never respond as the interface is set to serial. I think this was explained in book…maybe not


#16

Thanks Gus, but can you please tell me what I need to do to get the Panda running again so I can run .NET programs on it again?


#17

The info is more than a something I can tell you here…I need a book to explain it…even a book may not be enough :slight_smile: Even if you get NETMF to work, then where do you get the GHI exclusive features added to it?


#18

Ok :-[ I guess I’m going to order a new chip from GHI then I guess :slight_smile:


#19

I would suggest that you just buy a new Panda board. You might have problems with the circuit board after removing the chip for a second time and then resoldering.


#20

Ramon, I sent you an email :slight_smile: Please check it