Main Site Documentation

Having trouble debugging due to firmware version


#1

Hi. After being sick for many months, I’m getting back to my project, but I’m having trouble. I updated the firmware on my EMX project and the FEZ config reports the following:

HalSystemInfo.halVersion :4.2.0.0
HalSystemInfo.halVendorInfo :Microsoft Copyright © Microsoft Corporation. All rig
ClrInfo.clrVersion :4.2.0.0
ClrInfo.clrVendorInfo :Microsoft Copyright © Microsoft Corporation. All rig
ClrInfo.targetFrameworkVersion :4.2.0.0
SolutionReleaseInfo.solutionVersion: 4.2.11.0
SolutionReleaseInfo.solutionVendorInfo: Copyright © GHI Electronics, LLC
SoftwareVersion.BuildDate: Aug 15 2013
SoftwareVersion.CompilerVersion: 410713
LCD.Width: 0
LCD.Height: 0
LCD.BitsPerPixel: 0

My project compiles fine, but I get an error on deployment. I’ve tried deploying with NETMF versions 4.1, 4.2, and 4.3, but I get the same error no matter what version:

Found debugger!
Create TS.
Loading start at a0e00000, end a0e1383c
Assembly: mscorlib (4.2.0.0)
Assembly: Microsoft.SPOT.Native (4.2.0.0)
Assembly: Microsoft.SPOT.Security.PKCS11 (4.2.0.0)
Assembly: System.Security (4.2.0.0)
Loading Deployment Assemblies.

Attaching deployed file.
Assembly: Microsoft.SPOT.IO (4.2.0.0) Attaching deployed file.
Assembly: GHI.Premium.IO (4.2.11.0) Attaching deployed file.
Assembly: Microsoft.SPOT.Graphics (4.2.0.0) Attaching deployed file.
Assembly: Microsoft.SPOT.Hardware (4.2.0.0)


  •                                                                *
    
  • ERROR!!! Firmware version does not match managed code version!!! *
  •                                                                 *
    
  •                                                                 *
    
  • Invalid native checksum: Microsoft.SPOT.Hardware 0x7765AC69!=0xBF718024 *
  •                                                                 *
    

Attaching deployed file.
Assembly: Microsoft.SPOT.Touch (4.2.0.0)


  •                                                                 *
    
  • ERROR!!! Firmware version does not match managed code version!!! *
  •                                                                *
    
  •                                                                 *
    
  • Invalid native checksum: Microsoft.SPOT.Touch 0x4940D53E!=0x2D4E2DCC *
  •                                                                 *
    

Resolving.
Link failure: some assembly references cannot be resolved!!
Assembly: Microsoft.SPOT.Security.PKCS11 (4.2.0.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.2.0.0)
Assembly: System.Security (4.2.0.0) needs assembly ‘Microsoft.SPOT.Security.PKCS11’ (4.2.0.0)
Assembly: Microsoft.SPOT.IO (4.2.0.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.2.0.0)
Assembly: GHI.Premium.IO (4.2.11.0) needs assembly ‘GHI.Premium.System’ (4.2.11.0)
Assembly: Microsoft.SPOT.Graphics (4.2.0.0) needs assembly ‘Microsoft.SPOT.Hardware’ (4.2.0.0)
Error: a3000000
Waiting for debug commands…
The program ‘[3] Micro Framework application: Managed’ has exited with code 0 (0x0).

Any ideas what I need to do to resolve this issue? I did some searching on the forums and the solution always marked answer was to upgrade the firmware on the EMX. I’ve already done that … it upgraded to 4.2.11

Thank you.


#2

Hi there,

glad to hear you’re back onto your project.

This usually comes about because of old references embedded in an existing project. To validate that you can create a new project and copy over your code, or simply just create a new project and blink an LED, this should confirm you have the same SDK on your PC as matches the firmware.

The clean way is to start a new project as I said, but you can do this by removing all the references in your project, then re-add them.

Edit: Andre wins !


#3

Thanks for your help! I started a new project as 4.2 and it seems to work fine now. I’m not sure what I was doing wrong before. I had deleted and re-added all references. I think it has something to do with mscorlib not being re-added properly.

Rebuilding my project from the start took care of the problem.

Thanks again for your help!