Main Site Documentation

Have I killed my Cobra?


#1

I received my new Cobra on Saturday and have been messing around, trying out various bits of software.

I didn’t have too many problems, or at least I could figure out how I created the problems I had … until this afternoon. I was trying out Chris’s NOAA Weather API and I forgot to install an SD card in the socket. Of course, this caused an exception. The problem is, the PC doesn’t see the Cobra at all. I tried uninstalling and reinstalling the drivers, but no joy … no sound from Windows when I plug the board in, and MFDeploy doesn’t see it. I also have a Domino, so I tried plugging it in. Windows sees it, and I can ping it from MFDeploy. Does anyone have any ideas, or have I bricked my almost new Cobra? :’(


#2

Al:

I don’t have a EMX manual handy, but there are two levels of loaders. I think at the second level you can erase the application program.

This should fix the problem.

Worse case, reinstall all the firmware.


#3

After doing the Ldr button thing, does windows devices see the new comm port? Can you see from TeraTerm?


#4

Not having SD card should never cause any problems.

As the video points out, hold all buttons (up+select+down) down and reset the board to enter GHI loader…erase all and reload everything.

If still having problems, disconnect everything from the board and try again.


#5

Mike, William, and Gus -

Thanks for the help. ;D

I had tried unplugging everything and even rebooted the PC … that didn’t help. Windows couldn’t see the Cobra at all. I was able to access TinyBooter and then was able to reload the firmware through MFDeploy. The board is functioning again.