Main Site Documentation

Ghi bootloader this device cannot start. (code 10)


#1

Ok,

SO I loaded the 4.3 sdks and got ready to update the spider tinyclr

The GHI Bootloader Interface is Code 10 and there is no location in the properties to reset the COM port to anything other than COM5.
Am I doing something wrong,

Rebooted, restarted, uninstalled and reinstalled the driver 6 times.

Still no resolve.

Windows 7 64 bit.

Please help.

THanks


#2

OK, so next test please, start the Spider in CLR mode and see what device pops up ? And can you tell us the current version of the bootloader and CLR you have installed on the Spider?

The OS will decide what COM port to assign dynamically, so you don’t need to (and can’t) control that.

Can you uninstall the driver from Device Manager when its in the failed state, and please make sure you select the option to remove the files?

And one other recent comment from GHI was that they had seen specific USB ports get into this state, and trying different ports can help - that might mean through a different USB controller, so via a hub, or completely different port may assist.


#3

Here is the screen shot.

Looks like tiny is 4.2 and loader is4.2.10


#4

If I understand well your OS affects COM10 to your device. Then open a terminal (terraterm for example) connect to COM 10 using default settings and press enter. you should see “BL” printed on the terminal output window. Then you can update your board.

As far as I rememebt the FEZ config won’t be able to update the bootloader from 4.2 to 4.3. So you have to do it using terraterm


#5

True! I am lost about what is possible or not according to which HW and SW releases… :-[


#6

Ok. Can I reset clear wipe my spider and start over. any way to do that?

No matter what I try the COM driver wont work, I cant update the firmware to 4.3.

I can get my wifi rs21 to work on 4.2.10.

I am just rooked.


#7

@ danmeland - On your spider set the dip swith 1,2 and 3 in the on position. Power the board and start FezConfig. From the menu in FezConfig select: Advanced -> Loader (TinyBooter) Update -> Fez Spider and follow the instructions from the screen.


#8

Regards methods of update: The menus in FEZ Config can be consulted to see how a particular processor is flashed. Even if FEZ Config does not directly support the processor, it will have directions (or links to) methods for flashing.


#9

OK, so here is what I had to do to get this to work.

Uninstall all previous versions of netmf, Microsoft mirco framework, and any thing the related to past and present versions of Gadgeteer GHI Net.

clear boots, then reinstall only 4.3 and all the goodies.

I did as was suggested, and yep it worked.

Now to just update the 4.2 drivers I need to use, SEEED Relay, thermocouple, T35, and we will be off.

Thanks fro all the help.