Gadgeteer in VS2015?

Does this work currently? I tried installing the .NETMF and the Gadgeteer core from and then the rest from but I have no Gadgeteer project types when I try and start a new project in VS2015.

Do I need to change a setting to get Gadgeteer to show up as a project type, or is this just not doable yet?

It did not work for me when I have tried it.

It sometimes work, sometimes does not.

I suggest waiting for official releases.

1 Like

@ Squeebee - Did you get the ‘VS2015 Project System (alpha)’ file from (NOTE the term ‘alpha’ in the title).

1 Like

@ Duke Nukem - I didn’t, installed it and now I have a Micro Framework category when I start a project, any suggestions on getting a Gadgeteer category now? And thanks for helping me progress this!

I suspect you won’t have to wait but a few more days for an official release :wink:

Any news about this? I installed VS2015 and the other packages including the netmfvs14 package and I don’t get the Gadgeteer project category.


Microsoft still has to port Gadgeteer to work with 2015, which I am sure that is something they are working.

In the meatime I installed VS2013, uninstalled the mf and gadgeteer packages, but not VS2015.

After starting over, I have the same situation in VS2013. I can create a Micro Framework application, but no Gadgeteer application.

I also installed the “.NET Gadgeteer Builder Templates” from the gadgeteer website and now, I can create a Mainboard, Module and kit application for Gadgeteer, but no application.

Any ideas what to try next?

I did that. I followed the steps of this installation guide:

When only VS2015 was installed, the core installation finished nearly at once. Not it says that it is configuring Visual Studio. It just doesn’t seem to help much.

That is why I installed VS2013 as well after my first post and it is the same in VS2013!

I first tried the whole process using VS2015. After that didn’t work, I uninstalled the packages again, installed VS2013 as well and installed the packages from the guide again.

That means I installed vs 2013 first and then gadgeteer core.

Microsoft Framework SDK 4.3.2 runs on both 2015 and 2013, but remember not only installing the MSI archive, but also the netmfvsxxxx.vsix executable too!!
I have used them for programing an application on the new FEZ Panda III, on 2012, 2013, or 2015 VisualStudio using C# and runs fine. Don’t forget to update firmware on new boards first.
Gadgeteer runs on 2013, not 2015. But I don´t use it because FezPandaIII is not there. I use Net Framework Console Application instead, and you will found any reference dll supported for your programming.
I remember, in order to have templates or examples on 2012, I just copied the files of the examples and templates on the correct folder VS2012 and it runs, don’t know if gadgeteer is the same easy way.

Forgot to comment that I use VS 2012,13,or 15 installed and running at the same time with lot of versions of NetFramework and it works fine; on the project properties you can change the version you want to use, not needed to uninstall anything.
Hope it helps

Now I have started over with a clean Windows installation. (Virtual machines are great!)

This time I started with VS2013 and then installed the other packages and verything is working now. Maybe there is a glitch in the gadgeteer core installer which causes confusion when VS2015 is installed before.

Whatever it is, it is hopefully fixed in the next release. :wink: At least I can get started now. :slight_smile:

hi There

I like to ask if there are any issues with windows 10
If manages to install everything and in normal mode everything works finally

Firmware update and loader update does not. the boards (cerb net,cerb bee and fez spider are not communicating in the special modes for the update. I cannot even find them in the device manager. in the Firmware update the error "there is more than one device connected appears, even if they are alone connected to to my computer

please check it for me and give me some advice

best regards rene

There is another question

I installed first vs 2012 and 2012

then netfm 4.3
then core
then GHI SDK and vs2012.vix and vs2013.vix
everything available in vs2012 but not in vs2013

any ideas?

best regards

According to your list, you didn’t install vs2013… just vs2012 twice. That’s probably your problem.

I have installed VS2013 and the other tools on Windows 10 in a virtual machine on a Linux host. I just had to set the USB settings for the virtual machine to USB2 and everything worked fine. I did a firmware update using this configuration.