G80 Dev Board Display Configuration

Hi all!

I have just received my G80 Dev Board and the first thing that I tried is to get the Display up and running.
But I can’t get it to work, have tried the example in the User Manual and in the Gettings Started section, under Graphics.

The Display lights up, but no text or graphics.

Is there anyone that have a small example on how to confogurate and use the display?
Working with the Bitmap is no problems but to correctly configurate the Display is where Im failing.

My specs:
.NET Micro Framework 4.3
Firmware: 4.3.8.0
Visual Studio 2013

Regards,
Johan

@ jdahlgren - If you tried https://www.ghielectronics.com/docs/34/graphics#3271, did you update the pins to match the hardware on the development board? The pins used by the display are printed next to it on the board itself.

@ John - Hi!
I finally got it to work after some trial and error!
The examples does´nt match the current API and the printings on the card is hard to understand for a guy like me :slight_smile:

But this is what i finally ends up with:

CS = SPI.Configuration(ChipSelect_Port)
RS = Display.ControlPin
RESET = Display.ResetPin
BL = Display.BacklightPin

            
Display.Type = Display.DisplayType.Spi;
Display.Width = 128;
Display.Height = 160;
Display.BitmapFormat = Bitmaps.Format.Bpp16RgbLe;
Display.CurrentRotation = Display.Rotation.Clockwise90;
Display.SpiConfiguration = new SPI.Configuration(G80.Gpio.PD10, false, 0, 0, false, true, 8000, G80.SpiBus.Spi2);

Display.BacklightPin = G80.Gpio.PC7;
Display.ResetPin = G80.Gpio.PE12;
Display.ControlPin = G80.Gpio.PE10;

Display.Save();

Bitmap b = new Bitmap(160, 128);
Font font = Resources.GetFont(Resources.FontResources.NinaB);
b.DrawText("Hello, Display!", font, Colors.Red, 10, 10);
b.Flush();

@ jdahlgren - Glad to hear you got it working. The documentation will be updated for the final release of the SDK.