Main Site Documentation

G400-D Cannot Deploy


#1

Background…

Using VS 2010 Express
Windows 7 64 bit
G400-D
G400HDR
Tried with and without a T35 display attached

I have loaded the latest firmware.
This is the new package directed to by Gary (G400 Firmware and Pricing Update)
http://www.ghielectronics.com/downloads/beta/G400/
G400_Firmware_Version_4.2.10.0.zip

Copied into G400 Beta Programmer Folder - From G400 Beta Programmer(4.2.0.0)zip
config.hex
config.sig
firmware.hex
firmware.sig

I followed the 6 steps contained in How to use Programmer.txt

My G400 with T35 display attached shows on reset:

TinyBooter v4.2.0.0
G400 Build Date:
May 30 2013 14:18:41
Copyright GHI Electronics
TinyBooter GHI Version 4.2.10.0
Waiting

4.2.10.0 <-- I assume this is the firmware version that was installed

At this point I tried to Deploy and also tried Debug from Visual Studio a small test program
that does only Debug.Print(Resources.GetString(Resources.StringResources.String1));

The application does not Deploy or Debug the MFConsole application.
I once let it run for 30 minutes. Nothing… and it never deploys, fail, or time out.

From VS Output window:
------ Build started: Project: MFConsoleG400, Configuration: Debug Any CPU ------
MFConsoleG400 -> C:\Users\Will George\documents\visual studio 2010\Projects\MFConsoleG400\MFConsoleG400\bin\Debug\MFConsoleG400.exe
------ Deploy started: Project: MFConsoleG400, Configuration: Debug Any CPU ------

Side Note: Confused by this statement

Beta Firmware Update Procedure:
To update the firmware please use the FEZ Config tool found here: http://www.ghielectronics.com/support/.net-micro-framework

It fails if I try to use the Firmware Updater.

Should the new hex files be copied into
C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\G400\Firmware?

Anyway stuck in the mud here…

I’ll provide log file if needed. I’d post here but pretty long.


#2

@ willgeorge -

You don’t need to do that, but default FEZ Config Tool will point to that. If you did not point to new firmware files, it is may selecting the older firmware.

Make sure the firmware TinyCLR is running before deploying an application.
If it does not, press and hold LDR1 (I think that is PA4), press and release the reset button, still hold LDR1 until you see G400_G400 on MFDeploy (or FEZ Config tool), try to transfer the firmware again.


#3

And if this was happened, I highly recommend you should erase everything, even TinyBooter.


#4

@ willgeorge

It will be necessary to completely erase the initial version of G400 that was shipped out as TinyBooter was not included. We will update the Developer page immediately with this new information. Just follow the instructions for the TinyBooter update process and you should be good to go.

Please see the updated Developer page found here: http://www.ghielectronics.com/docs/112/g400


#5

So much for skipping the first part of the instructions! Thx Aron.


#6

@ Aron -

Thank you for the reply!

Can you provide steps I should use to erase my G400. I don’t want to mess it up.


#7

@ willgeorge

Just follow the steps outlined here: http://www.ghielectronics.com/docs/112/g400#1687 under the Beta TinyBooter Update Procedure. These are the correct steps to follow.


#8

@ Dat -

Should the new hex files be copied into
C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\G400\Firmware?

I did NOT do that. Just a question.


#9

@ Aron -

Sorry… Block head here…
I thought I did that…

Image shows folder on my PC that I used to update.


#10

@ Dat -

I’ll try your suggestion using the LDR buttons.


#11

UPDATE on my Issue… I can now Deploy/Debug through VS 2010

Thanks for staying with me to all that replied.

Upon firmware update AND reset/power on the G400 would always display:

TinyBooter v4.2.0.0
G400 Build Date:
May 30 2013 14:18:41
Copyright GHI Electronics
TinyBooter GHI Version 4.2.10.0
Waiting

It now displays the following upon reset:

Version: 4.2.10.1
Debug: USB
LCD: 480x272 (not the display I am using but who cares at this point)

Waiting for debug commands…

What I did was use the MS .NET Micro Framework Deployment Tool Version 4.2.0
Image File panel, Browse… button, Deploy button.

See attached image.

All it took was to deploy the hex files from the new Download folder I created for the new firmware. Not sure why they were not loaded using the update procedure outlined.

Anyway it is working now!

Sorry I can’t check everyone that pointed me in the right direction for the answer. Everyone helped!


#12

No, it is not needed. Once you go through the TinyBooter Update Procedure, you will need to reset the board and then activate the FEZ Config tool. Go to the Firmware Updater tab and select G400. Click on the browse button and navigate to the proper folder that the firmware hex files are at and select those files. Click next and it will update/install the firmware.


#13

@ Aron -

Not picking on it but the FEZ Config did not help me…
Go to the Firmware Updater tab and select G400. It would error out saying it was not connected or something like that.

The MFDeploy worked…
I have used the same Image File deploy on my Spider and EMX when I hade issues in the past.

Not sure why I did not think of it before.


#14

I am having a similar issue, have seen the “updated” procedure but still have a issue.

I have followed the “Beta TinyBooter Update Procedure:” but I don’t think it is completing the programing of the TinyBooter.

The log file ends with the following, is this a failure or successful log?

-I- Complete 98%
-I- Writing: 0x2A0C bytes at 0x162C00 (buffer addr : 0x20008FEC)
-I- 0x2A0C bytes written by applet
GENERIC::SendFile G400-TinyCLR-Bootloader.bin at address 0x0
-I- File size : 0x2290 byte(s)
-I- Complete 0%
-I- Writing: 0x2290 bytes at 0x0 (buffer addr : 0x20008FEC)
-I- 0x2290 bytes written by applet
-I------------------------------
-I- Script Completed
-I- Please Reset the Device
-I------------------------------

There was mention of erasing the G400-D but not sure how to do that either.

When I check the Versions with FEZ Config the TinyBooter is blank, TinyCLR is 4.2.0.0


#15

@ PHITEK
I believe you are using the incorrect programmer. In the developer page, go to the link and re download the beta programmer file as the programmer has changed slightly to accommodate the TinyBooter instead.


#16

@ Aron
Thanks that fixed my issue.