Main Site Documentation

G120 to 0.7


#1

hmmm, using TinyCLR Config to upgrade a G120 Fez Cobra II G120
from v0.4 to 0.7 I get “There was an error during the upload”

I can re-install v0.4
But 0.5, 0.6, 0.7 all fail…

G120
File Date Status MD5
v0.7.0 2018-01-04 Alpha 54F03A598791E8062096EE67ACA8C25A
v0.6.0 2017-08-31 Alpha 9418A57C0B5F655F3FD35CBED0CEC16F
v0.4.0 2017-05-10 Alpha 1C09A3C7D5305B03F0FF51884ACBD2F2
v0.3.0 2017-04-06 Alpha 57836246074A8E729EE3D6C6BCF76F55
v0.2.0 2017-03-07 Alpha 66EAA71A4A7D1B96AC9CD7C892DAA3CE

hmmm same with FEZ Raptor G400


#2

Are you using the Update Firmware button or the Loader tab?


#3

Yes Update Firmware, it checks for updates, then says "no update found"
The firmware sources file seems ok

1,Network,http://files.ghielectronics.com/downloads/TinyCLR/Firmwares/FirmwareList.xml

and if I download this i do see an entry for G120 0.7

Loader tab, Update “There was an error duiring the upload” if I manually download 0.7 G120 FW from github downloads


#4

Where are you getting the G120 0.7.0 from GitHub?


#5

via github link to
http://docs.ghielectronics.com/tinyclr/downloads.html


#6

Have you verified the hash of the file you downloaded matches what is listed on the site


#7

yes it does match
but havent hashed the actual file to see if it also matches…

— have now, and yes the file also hashes to correct hash


#8

Do you have a different PC you can try the update on?


#9

I’ll try tomorrow… but cant see why .4 reload works fine on this pc


#10

hmmmm…
A new fresh windows 10 install (updated) laptop.
Same error.
Noticed v0.8 has been released since, and that also says "error during upload"
But can ping, erase the G120
hmmmmm… I’ll try my G400


#11

OK, seems TinyConfig v8 needs to have Bootloader v2.0.4
Had to update using TeraTerm serial port / xmodem
I saw that it needed v2
http://docs.ghielectronics.com/tinyclr/tinyclr_config.html
But I did have v2.0.2 and thought that was enough.
Should have tried getting EVERYTHING up to date (of course, and I thought I was, didn’t see 2.0.4 pop up)
TinyConfig now works and can now upload v 0.5,0.6,.0.7 firmware and seems to communicate as expected (apart from a few crashes when swaping comm ports, seems to occasionaly not like seeing comm ports disapear maybe…)


#12

Sorry about the confusion around loader versions. Newer firmwares do indeed need v2.0.4. Happy to hear you got it working though.