Main Site Documentation

G120 TinyBooter update does not work


#1

Hi everyone,

Recently, I found that my G120 did not let me deploy any code on it, so I checked the device connection with FEZConfig (v1.0.0.0). Pinging the device failed.
So I reset the device and started TinyBooter.
An update check for the device showed following information:

Loader (TinyBooter) version information:
4.2.11.1 on this computer.
4.2.10.0 on this device.

The Loader (TinyBooter) not up to date. <<<

Firmware (TinyCLR) version information:
4.2.11.1 on this computer.
Firmware (TinyCLR) Version: Not available.
The device is in Loader mode.

So I thought I had to reinstall the firmware. But before I could do this, I knew I had to update TinyBooter.
I followed the instructions in FEZConfig and reset the G120 in GHI Boot Loader.
The GHI Boot Loader Interface showed up in my Ports (COM & LPT) section and I was ready to go.
But the update did not start and instead showed me the message attached to this post.

Then I tried following operations:

  • TinyBooter update with power supply plugged in
  • TinyBooter update using G120Updater v1.0.4
  • Reinstalling the USB drivers (x86)

Nothing of the above mentioned operations worked.

Is there another way to install the TinyBooter update?
Or is there a possibility to install the TinyCLR Firmware without having the latest TinyBooter?

Thanks for your help.

Regards,
S.J.


#2

Can you show us the Device Manager view when you’re in boot loader mode? If the driver loads correctly you should be able to deploy the G120 bootloader update first no worries, and we can help walk you through that if the troubleshooting steps the app linked to didn’t help?


#3

Hi Brett,
I could have showed you that the driver appears correctly in the device manager window when the device is in bootloader mode. But I figured out the problem and solved it by now.

I had a USB Bluetooth adapter installed, which created several virtual COM ports to bind different devices to. One of the automatically created COM ports was the exact same as the automatically created COM port of the GHI.

I deinstalled the USB Bluetooth adapter drivers and could then install the Bootloader update on the GHI G120. (But for this time I did not try the FEZConfig but instead used UTF-8 TeraTerm).

Thanks for the help and have a nice day.

Regards,
S.J.


#4

awesome news that you’ve sorted it out !