Main Site Documentation

G120 stop responding after updating R3


#1

I install NETMF and Gadgeteer Package 2013 R3.zip (125.24 MB)
I used FEZ config, clicked Firmware Updater and update the device. I noticed that I didn’t need to reset the device in boot loader. The update finished successfully.

Now the G120 icon appears in windows Devices and Printers window. After 60 seconds the G120 icon disappear and reapers again and again disappears …
The FEZ Config and Net Micro Framework Configuration Tool found device, but both programs can not pin the device.
The CP7 is white. I already try to unplug the display, reset it, remove power source, load in TinyBooter and press reset button again.

I ran out of ideas. What now?


#2

R3 has a new boot loader, so you should update it to.
This option is hidden in Advanced menu.
GHI never answered any question what would happen if you don’t update the bootloader, and fore some FW versions I tried it not updating it, but I haven’t tried for R2->R3.

And you have running FEZConfig 2 times. Can’t see what the 2nd one is connected to. May be it’s blocking the other one.


#3

Thank you.
I would mark your answer as correct, but apparently this option has been disabled, since I can’t find the button.


#4

@ Makla - It was removed by GHI, because it was rarely used.
You can use the +1 if you like
:wink: