Main Site Documentation

G120 Create Application Deployment problem


#1

I am not able to create an application deployment file with MFDeploy or the GHI .net configuration tool V 0.0.3

MFdeploy (4.2) returns an error message “Device has old or unsupported” configuration (see attached image)

While GHI configuration tool creates a file with zero length…

I tried different possibilities:

  • erased all memory using mfdeploy
  • re-flashed the device (Cobra II) with firmware 4.2.10.1 and loaded the application.

Nothings seems to help, @ GHI can you please advice?


#2

@ RobvanSchelven -

I just tried with FEZ Config tool 013,

  • Deploy PhilM’s code about ENC28 problem by VS2010.
  • Then use FEZ Config tool 013 to extract out a HEX file.
  • Deploy that Hex file by FEZ tool again

It is OK.


#3

@ Dat - Thanks, maybe i use an outdated config tool (0.0.3) will download and test with 0.1.3


#4

Unfortunately V.0.1.3 gives the same result as V 0.0.3 The file that it creates is zero length. I am using the WINUSB driver. Do you know if that could be of influence?


#5

Update… this seems to work…

VS -> deploy application… (DON’T RUN IT)
Configuration tool -> create HEX File

Creating a HEX file when the application has run ones will fail and result in a null length hex file.

Maybe because i use RLP??