G120 CAN Bit timing II

I guess you’re using USB2 ?

I tried different ports and cables with the same result.

Current status :
2 from 3 G120HDR boards have been trashed by the failed update, behavior in de device manager :

(something went wrong with the capture but start looking at 1.20 to see whats happening)

I now tried MFDeploy but there also o error as in the screenshot

@ David@ Emrol - It is really near impossible to trash a device due to firmware update. Check your power and try a different PC please.

Hi, i can believe it’s near impossible but i have an issue that completely stops me and don’t know what else to check.
The firmwarei try to use is : G120 Firmware Hotfix v4.2.9.1

I tested on a different pc and monitored the voltage (3.29-3.30 all the time)

this is what happens :

Everything looks ok, you see connection is made, update is done, reboot, you see the boot loader driver disappear and the Debug interface is showing up, firmware update is done, and at executing application it hangs for a few minutes and then you get the last error or an application crash.

Behavior is exactly the same on a different pc.

I just did a firmware update from my home computer back to 4.2.7 :

Firmware updated sucessfully. Version number:
Updating TinyBooter and Firmware is complete!

And this is succesfully :slight_smile: so i start to think i maybe dont have downloaded the correct firmware version?
What’s the location of the latest 4.2.9 please?

I downloaded the one from :


Update run’s until rebooting and then the updater freezes, see screenshot…

Update back to 4.2.7 = no problem

– Log –
Connecting to device…
GHI Boot Loader Interface found at Port#: COM3
GHI Bootloader Version: 1.01

Device will be updated automatically! DO NOT disconnect or turn off the device!
Erase successful!
Updating TinyBooter. Please wait…
Update successful!
Disconnecting COM3
TinyBooter updated sucessfully. Version number:
Updating Firmware. Please wait…
Deploying C:\Program Files\GHI Electronics\GHI Premium NETMF v4.2 SDK\G120\Firmware\Config.hex … successful!
Deploying C:\Program Files\GHI Electronics\GHI Premium NETMF v4.2 SDK\G120\Firmware\Firmware.hex … successful!
Deploying C:\Program Files\GHI Electronics\GHI Premium NETMF v4.2 SDK\G120\Firmware\Firmware2.hex … successful!
Firmware updated sucessfully. Version number:
Updating TinyBooter and Firmware is complete!


Alway’s have 1 of these 3 results after updating to

  • Updater freeze
  • Updater message could not connect check if pin xx is high (but check screenshot 2 : the device is detected OK)
  • Blue screen of dead…

Update back to 4.2.7 is always ok

On the video, it looks like if when the camera turn to the test board, your pin LDR0 and LDR1 are joined together ?

If this is true, note that the beginning steps are :

  1. Join together LDR0, LDR1 with GND
  2. Press Reset, to reboot the board,
  3. When rebooted, put LDR0 and LDR1 in the air

Do not let LDR0 and LDR1 together during the firmware update, as when the board will reboot after update, it will reboot in Update mode however the process is waiting for the Normal state to appear…

Not sure I’m very cleat explaining this…Ask if not :slight_smile:

I have been on this a complete day now and created a screen vid… but the sound messed up so I give you a overview :
(you still can hear device connect and disconnect sounds)


Transcript :

  • started with a G120HDR with a failed 4.2.9 version
  • update to 4.2.7 with success at about 02:00
  • put back in correct boot mode at about 02:43
  • started update to 4.2.9 at about 03:08
  • updater freeze at about 03:30
  • then I paused, restarted updater and put G12HDR in correct boot mode to start update to 4.2.9 again at about 04:12
  • reboot at about 06:00 there you can check what driver is used
  • and 07:00 you see the message the device is not there etc etc etc and at the same time you hear the device disconnect sound
  • and reconnect at 07:08
  • from here the G120 will disconnect every minute at 08:08 the first time
  • I started again at 09:00 with a downgrade to 4.2.7 but this freezes at 09:50
  • so I restarted updater, put back in boot mode at 10:33 run the update to 4.2.7 with success at 11:53

So until now I checked :

  • power during update, keeps at 3.29-3.30
  • just to be sure replaced the power supply with one from the lab
  • I verified the downloaded firmware
  • I tested on 3 different computers (all the same results)
  • did more then 50 setup’s to try to isolate the problem the last 14 hours today

Results :

  • I can’t do a successful firmware upgrade to 4.2.9
  • I can do a successful firmware downgrade to 4.2.7
  • behavior after unsuccessfully firmware upgrade looks like the G120 is rebooting by internal watchdog or so every 60 seconds
  • the G120 is correctly detected in the device manager in all states


  • Can I buy some GHI support hours to check this out?
  • Should I go back to EMX and combine this with Hydra maybe?
  • Should I throw 1500 € GHI devices in the trash and explore other possibilities?

I don’t know but i’m frustrated right now… what else can I check???

@ LouisCpro - Yes but already changed this, in the last screen vid i always had the LDR0 an 1 open, no difference.

This issue probably will be solved, i did a new test setup today to isolate the problem.
I combined a EMX with 2 CAN ports and 2 G120HDR boards to 1 CAN bus with a simple “ping pong” app between the 6 ports and there is only 1 port that causing the buss off errors, i guess i have blown this port playing at my desk without esd protection instead in the lab where we have esd safe tables and wristbands…

this sounds plausible?

Very unlikely but possible. Trying other devices will tell you for sure.

Will replace this board in the morning and connect the whole setup in a loaded CAN environment, if this all works i “can” go back to programming :wink:

Replaced the G120HDR in a new test setup with about 60pins wired to 3 breadboards to test the complete core program functionality and there i noticed some realy weird behavior caused probably by interference between the different signals. I replaced most data connections with shielded connections between the G120 and the breadboards and almost everything runs fine on maximum speeds.

Have you pulled slope controll pin on the tranciever to gnd? or make sure it has low level so it’s in normal mode.

yep, pulled to gnd.