G120 Primary DNS bug? Gateway address is shown

Setting and Getting DNS addresses show different results.

input dns = &
output = & is actually the gateway address

See also output from FezConfig

if (!_nic.IsOpen)

     _nic.NetworkInterface.EnableStaticDns(new[] { "" , "" });

     var dns  =_nic.NetworkInterface.DnsAddresses;
     foreach (string s in dns)
             IPAddress ip = IPAddress.Parse(s);
             DebugHelper.Print("DNS=" + ip.ToString());

@ RobvanSchelven - Information on which primary DNS server to use can also be supplied by the DHCP transaction. Is the issue persistent when using a static IP address?

@ James - Thanks for your reply. In the example i supplied DHCP was indeed on. It was not the intention to turn it on. It seems that EnableStaticDns does not change the primary DNS when DHCP is on. In static mode its works fine.

Does it make a difference if you attempt setting the static DNS addresses after the DHCP transaction is complete and an IP addresses has been granted?

This is similar to a problem I’m having of changing the DNS address in DeployMF or FezConfig. Somehow the mainboard’s network setting seem to have it locked in their head to use a DNS Address from one of my other test networks, and it doesn’t seem to matter what I do, I can’t change it, suggestions? Of course when I use it on network, all my DNS calls fail.