FT232R Help

I guess i must be a legend then as i use USB 3 for both without issue :slight_smile:

As for the FTDI it just means when you plug it in to USB 3 it runs at the USB 2 spec.

2 Likes

fundamentals. With nothing BUT the FTDI module connected to your PC, and nothing downstream of it, you should get a PC USB connect noise and see the device in Device Manager. If you don’t you have a fundamental issue like wiring USB D+/- pins and PWR/GND wrong (assuming you’re set up right for using USB bus power)

I have no idea if this is correct or not but I remembered seeing this. I do not have the module to test.

without a driver, you’ll still get the device connected noises if it can detect a USB device. You’ll then see the device in the device list in Device Manager, with the note. So until you can see a device in the list, you don’t need to bother with drivers… and most modern OSes will deal with FTDI driver out of the box. There’s no reason that the WHQL approved device won’t be installed if the vendor has put it thru the right process so a manual workaround is usually unnecessary

For the fundamentals - looking at the back of the USB receptacle (the side where the pins are visible, not where the USB male plugs in), from this angle Pin4 (GND) is on the left, Pin 3 goes to USBDP on the FT232 (pin 15), Pin 2 goes to USBDM on the FT232 (Pin 16), and pin 1 (VCC) has a 10nF cap goes to ground and a ferrite bead going to Vcc part of my breadboard.

Sound correct?

Sounds correct and if you have it wired similar to below you should get the windows bing bong as Brett mentioned.

1 Like

That is exactly how it is wired. That is the schematic I used. I wrote all pin numbers on that schematic before soldering (and double checked I wrote the correct numbers for my package). Don’t get any connection to the computer still. I am thinking it is this random cable I dug out of a drawer it has another plug in parallel to the USB.

stop thinking start replacing :wink:
the cable…

1 Like

Had to drive 45 mins to get a new cable, needed to get supervisor’s approval haha. AND WE HAVE A WINNER! It was the cable. It instantly registered with the computer and installed some drivers…

…However, it registered as a USB mass storage device and not a COM port. I am guessing the drivers did not install correctly. It was previously sending 5V to it and now the USB bus is not sending power.

then I’d say you have a short on the device somewhere and the PC is protecting itself by shutting it down. And I’d say you probably have a USB stick inserted that is the storage device.

I’d do disconnect, reconnect, tests and validate what device comes up (then goes away). The dodgy cable may in fact have damaged things, although it doesn’t sound like it would have given the behaviour you saw. I’d expect you’ll see 5v power at the start until the overcurrent protection kicks in and shuts things down - that conclusively is a short

The other cable did not damage anything it was running at 5 V until I unplugged it and switched. I most definitely do not have a USB drive inserted. I plugged in my FT232 chip with the new cable and it immediately said installing driver software complete and the Mass Storage popped up in Device Manager. Its possible I shorted it while changing the cables but if I did, why would it suddenly install device drivers? What would the voltage be on a mass storage device? Would current go through one if there was no data transfer?

uninstall the driver associated with your “USB mass storage device” and install VCP driver from FTDI
if you still have no Serial Port check the FTDI manual regarding “Operation configuration mode and USB Description strings configurable in external EEPROM over the USB interface.” because its possible the chip identifies itself “wrong”

I did install the VCP driver prior to plugging it in but maybe there is a second driver I have to install? It was confusing as I read several different things.

right click properties and check what driver is in use…
normally its enough to install one driver, as long as its the right one :wink:

Ok so the driver I installed orignally (and just reinstalled) contained both drivers needed (VCP and D2xx.dll). Unplugged my chip and plugged it back in, same results.

Going to see if MPROG can connect to change the EERPOM registers.

Also I just tested with a second chip and it gives the same results, it was not a short.

It opens up some app called EasySuite after the driver installs.

Windows 10 - FTDI driver v2.12.28.0 from here http://www.ftdichip.com/Drivers/D2XX.htm

Have you tried updating the driver, selecting browse and pointing to the driver folder you extracted from the download?

Should look like this:

My Quick Access Group does not have those fancy blue lines. Where did you get them from?

1 Like