Friday Gadgeteer Module Offer 06

YES! It’s time for another contest! This would be a great way to generate some Gadgeteer buzz! (no, I’m not suggesting another piezo contest) I would recommend a general project contest based around some theme or a competition for the coolest way to achieve some task.

I shall mull it over.

:wink: plans are a foot

1 Like

@ Justin - Where can I download the driver for this?

@ ianlee74 -

1 Like

Thanks, Justin! I’ve got a bug fix for you :wink: Please add this to the first line of Buzz().

        public void Buzz(int length = 100)
            if (length == 0) return;

Here’s a new one… I tried doing a release build of your driver to generate the installer and I get this error…

[quote]"Error 1 The “Candle” task was not found. Check the following: 1.) The name of the task in the project file is the same as the name of the task class. 2.) The task class is “public” and implements the Microsoft.Build.Framework.ITask interface. 3.) The task is correctly declared with in the project file, or in the *.tasks files located in the “C:\Windows\Microsoft.NET\Framework\v4.0.30319” directory. D:\Temp\Buzzer Module\Buzzer\Buzzer\Buzzer.csproj 88 5 Buzzer

Does this mean anything to you?

Erm, nope…
Never heard of a Candle task…

:frowning: Would you mind adding the bug fix and sending me a new installer? I need to demo using the toolbar and it makes a god awful constant chirp w/o that fix :wink:

Will do, cant do untill i get into the office…
Unfortunately you have an original v1 with missing pull down…
What board do you get that on as i never had any issue with v1 on Cerb and only on premium boards as the pins are floating…

The problem is that I’m running it in a loop with a slider deciding the volume. If I have the slider down to zero then I still get a constant short chirp. I could put an if around the Buzz() call but I don’t want to have to explain that there’s a bug in your code :smiley: I’m trying to make you look good, brother…

            var timer = new GT.Timer(250);
            timer.Tick += timer1 =>
                    _sliderPos = (int)(slider.GetSliderPosition()*100);


@ ianlee74 - I need all the help i can get to look good :whistle:

I suppose it really should have some threads in there as well…

@ Justin - Thanks! Much better.

Does this mean anything to you?

I’ll answer this one for future reference. Typically ‘Candle’ errors are related to WIX which is used to build the installer which is why you only see it on ‘Release’ builds. Which version of WIX do you have installed, as I suspect Justin (and just about everyone else who builds installers for modules) uses the .NET Gadgeteer Builder Templates from the Gadgeteer CodePlex site ( Currently this template requires WIX 3.5 also from CodePlex ( Once you have WIX 3.5 installed this error should go away.

Now if WPF was only so easy to explain, are there drugs that can help a person understand some of the inner workings of WPF?

@ Duke Nukem - Good info cheers…

Didnt the Stones say it was the yellow pills? :smiley:

Thanks for the info, Duke. I had all of that setup at one time but I probably haven’t reinstalled that bit since my last rebuild.

Installing Wix did indeed fix the problem. Thanks again, Duke.