Fly over an F7

For Lutz1 and all others trying to play with the new STM32F7 Discovery board.

This document covers the demo software http://www.st.com/st-web-ui/static/active/en/resource/technical/document/user_manual/DM00190393.pdf with instructions how to make your own video files. All files must be on a micro usb stick inserted in CN12 (USB_HS)

The Stm32CubeF7 software covers a lot on used sources including the driver sources to be found amongst very other resources on http://www.st.com/web/catalog/tools/FM147/CL1794/SC961/SS1743/LN1897/PF261909

1 Like

Thank you very much, .Peter.

Today I recieved a new USB Memory with two connectors : USB and Micro-USB
I copied the media drectory from Stm32CubeF7-zip

… and it worked !
My F7-DISCO is now playing/recording audio files and playing video files :slight_smile:

So my problem was the adapter cable. :frowning:

@ Lutz - That’s cool !!

I’ve tried a bit and converted a three minute video, recorded it.

Sorry about the shakin stevens look but it seems I’ve got a strong heart, full of excitement here.

2 Likes

Hello .Peter.

that looks great !

So at next, we only need a STM32F746 port for .NetMF 4.4 … :whistle:

@ Lutz - You might be in for a surprise … :open_mouth:

  1. A nucleo with the F7 is to come somewhere near the end of this year.
  2. CW2 is trying to get netmf 4.4 working on the nucleo F411RE
  3. The F7 “ought” to be software downwards compatible with the F4
  4. Getting the NucleoF411RE Netmf 4.4 SW working on a basic F7, shouldn’t be that hard … :think:

If I only had a landscape of how the project structure is for netmf, I would try to make it with VisualGDB 5.0, that has support for the F7 … that way it could be possible to have it all in VS2015. One solution with a project for the 4.4 FW and the 4.4 C# based app in one or more projects on top of that …

@ .Peter.
Sounds good :slight_smile:

So I will have enough time to build my own hardware based on the F7-DISCO …
There is only one chip which is only available in BGA, … I may have a good chance. ::slight_smile:

@ Lutz - Ehm, if you order from didgikey and above 65 / 70 euro you get it shipped for free. I already have gotten my products in 3 days shipped from digikey warehouse in US. (They’ve got a UPS office on the warehouse park to speed up deliveries).

And they do have LQPF in 4 flavours … on stock …

[url]http://www.digikey.de/product-search/de?pv16=1111&pv16=1223&pv16=2488&pv16=3024&FV=fff40027%2Cfff800cd&k=STM32F7&mnonly=0&newproducts=0&ColumnSort=0&page=1&stock=1&quantity=0&ptm=0&fid=0&pageSize=25[/url]

@ .Peter.

Yes I know.
F7xx, RAM, USB, Ethernet and QSPI-Flash are all available in (T)LQFP cases.
But the sound chip is only available in BGA.

@ Lutz - I hope that will than be changed over time … :wall: :wall:

@ Lutz - what do you mean by “audio chip” and via what bus/pins would than be the differance ?

@ .Peter.
“Audio chip” : WM8994ECS/R on schematic “stm32f746g-disco_sch.zip\mb1191\schematics\audio.SchDoc”

[url]Cirrus Logic, Inc. | Cirrus Logic

It has been working for a few days now, with full GCC support. The code is available in my repo, see the original post on NETMF github (the branch has been updated). I have not yet announced it publicly, because the peripherals need some more work and testing and unfortunately due to extreme hot weather that hit our country I could not spend as much time as I need to finish it.

2 Likes

I understand, it was 78 F here today and I could barely think! :whistle:

I would probably melt

I think I would like to visit on vacation one day, but that would be it, unless I had a place on the beach.

Update :

It was not the cable or USB Memory.
All works fine if I use the original HEX-File from
"stm32cubef7.zip\STM32Cube_FW_F7_V1.1.0\Projects\STM32746G-Discovery\Demonstration\Binaries"

But if I compile the sources from
"stm32cubef7.zip\STM32Cube_FW_F7_V1.1.0\Projects\STM32746G-Discovery\Demonstration\MDK-ARM"
no files on USB memory are found…

So I asked for it in the ST-Forum and this is the answer :

There is an error at the source “usb_msc.c” :’( :wall:

Repository\STM32Cube_FW_F7_V1.1.0\Middlewares\ST\STM32_USB_Host_Library\Class\MSC\Src\usbh_msc.c
line 446, change


to 

```cpp]if((phost->Timer - MSC_Handle->timer) < 10000)[/code


Now every things works fine... Time to go on. ;)
I hope that will help somebody else !
1 Like

@ Lutz1 - Bummer, but glad you could solve it. If you got netmf running can you let me know :whistle:

  1. Tossed an F7 (STM32F746ZG) in a board that had an F4.
  2. Deployed TinyBooter, didn’t work.
  3. Looked at source, saw references to core_cm4.h, replaced those with references to core_cm7.h.
  4. Recompiled, ran S19 to DFU and re-deployed TinyBooter…

Didn’t work.

Any ideas? It shows up in DFU mode of course, but after I deploy TinyBooter it doesn’t show up as a USB device of any type.

Flash start address changed from 0x0800 0000 to 0x8080 0000 or something like that. SRAM2 also moved. So I presume the scatterfile needs an update?

As well as the memory changes Boot is different also changed…

Have you looked at the below?