Main Site Documentation

First GadgeteerApp Fez Hydra issues


#1

I’m using Visual Studio 2010 Pro
I followed the installation steps from http://www.tinyclr.com/support:
except for VS express.

Then I created a GadgeteerApp --> in designer dropped 2 relays from Seed. And one Ghi SDcard.
Added something like this:

        Debug.Print("Program Started");

        relays.DebugPrintEnabled = true;
        relays1.DebugPrintEnabled = true;

        relays.Relay1 = false;
        relays.Relay2 = false;
        relays.Relay3 = false;
        relays.Relay4 = false;
        relays1.Relay1 = false;
        relays1.Relay2 = false;
        relays1.Relay3 = false;
        relays1.Relay4 = false;

        while (true)
        {
            relays.Relay1 = !relays.Relay1;
            relays.Relay2 = !relays.Relay2;
            relays.Relay3 = !relays.Relay3;
            relays.Relay4 = !relays.Relay4;
            relays1.Relay1 = !relays1.Relay1;
            relays1.Relay2 = !relays1.Relay2;
            relays1.Relay3 = !relays1.Relay3;
            relays1.Relay4 = !relays1.Relay4;

            Thread.Sleep(200);
        }

Everything I try I get in debug:

Invalid native checksum: GHIElectronics.OSH.NETMF.Hardware 0xE23395B!=0xEFA246E0

Resolving.

Link failure: some assembly references cannot be resolved!!


Assembly: GTM.GHIElectronics.SDCard (4.1.1.0) needs assembly 'GHIElectronics.NETMF.IO' (4.1.8.0)

Error: a3000000

Waiting for debug commands...

The program '[2] Micro Framework application: Managed' has exited with code 0 (0x0).

In emulator I get:

Using mainboard GHIElectronics-FEZHydra version 1.0
    #### Exception System.NotSupportedException - CLR_E_NOT_SUPPORTED (1) ####
    #### Message: 
    #### Gadgeteer.Modules.GHIElectronics.SDCard::MountSDCard [IP: 000d] ####
    #### Gadgeteer.Modules.GHIElectronics.SDCard::.ctor [IP: 007f] ####
    #### GadgeteerApp2.Program::InitializeModules [IP: 0006] ####
    #### GadgeteerApp2.Program::Main [IP: 0010] ####
A first chance exception of type 'System.NotSupportedException' occurred in GTM.GHIElectronics.SDCard.dll
SDCard ERROR : Error mounting SD card - no card detected.
Updating display configuration. THE MAINBOARD WILL NOW REBOOT.
If you are deploying/debugging using Visual Studio, you will need to stop (Shift-F5) and start debugging again (F5). 

When I remove the SDcard from designer and the referenced dll’s I get:

The debugging target runtime is loading the application assemblies and starting execution.
Ready.

Cannot find any entrypoint!

Done.

Waiting for debug commands...

Anybody has some advice what I’m missing here?


#2

It seems like you might have the incorrect firmware on the board if you have the latest SDK. Also, the emulator will not support any GHI specific libraries.


#3

Do I need to follow theses steps are is there some GUI tool like FEZ Spider,…

http://wiki.tinyclr.com/index.php?title=Firmware_Update_FEZ_Hydra


#4

Follow those steps…


#5

There will be one with the next SDK, which will be out shortly.


#6

After following all the steps of updating the firmware (with the wire in 8 en 10 for max 5sec)
The project is working with the two relays :smiley:

Now I have added the sdcard (GHI 1.4) in the designer and start debugging I get the following exceptions:

#### Exception System.Exception - CLR_E_DRIVER_NOT_REGISTERED (2) ####
    #### Message: 
    #### Microsoft.SPOT.Hardware.NativeEventDispatcher::.ctor [IP: 0000] ####
    #### GHIElectronics.NETMF.System.InternalEvent::.cctor [IP: 0014] ####
An unhandled exception of type 'System.Exception' occurred in Microsoft.SPOT.Hardware.dll

 Uncaught exception 
The thread '<No Name>' (0x2) has exited with code 0 (0x0).
Using mainboard GHIElectronics-FEZHydra version 1.0
    #### Exception System.NotSupportedException - CLR_E_NOT_SUPPORTED (1) ####
    #### Message: 
    #### Gadgeteer.Modules.GHIElectronics.SDCard::MountSDCard [IP: 000d] ####
    #### Gadgeteer.Modules.GHIElectronics.SDCard::.ctor [IP: 007f] ####
    #### GadgeteerApp2.Program::InitializeModules [IP: 0006] ####
    #### GadgeteerApp2.Program::Main [IP: 0010] ####
A first chance exception of type 'System.NotSupportedException' occurred in GTM.GHIElectronics.SDCard.dll
SDCard ERROR : Error mounting SD card - no card detected.

Program Started


#7

There will be a very important SDK release tomorrow. You must update again. Sorry :slight_smile:


#8

are you talking about the GHI SDK?..for the Hydra?


#9

Yes, after updating the firmware of my fez hydra the relais started to work, but when I add sdcard in gadgeteer designer in VS2010 and run the project I get the above problems.

It’s a sdcard from ghi version 1.4.