Main Site Documentation

Firmware Upgrade


#1

I have watched the video and read the documentation, but I am still am having difficulty upgrading the firmware on the Panda-1. I have tried this upgrade process multiple times on different 32-bit and 64-bit Win7 PCs and can reproduce the same result every time. I have also tried to uninstall and then reinstall the software (MS NETMF4.1 SDK and GHI NETMF 4.1 SDK) and drivers (32-bit and 64-bit) to correct the problem. The upgrade results are as follows:

1) MF Deploy program cannot connect to the Panda (USB or Serial)
2) All Systems are able to connect to the Panda using Tera Term over a serial connection 
3) After holding down the LDR button and connecting the USB cable, I get the following results:
	Enter 'V' - 1.07
	Enter 'E' - Erase all memory! Are you sure?
	Enter 'Y' - Erasing . . . BL
	Enter 'X' - Start File Transfer 
		    CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC

	Transfer/xModem/Send 	File: USBizi_CLR.GHI		Option: 1K
	Watch as the bytes register that they are transferring
	Results: File Transfer Finished Successfully
		Bad firmware
		BL

I need help in understanding what is happening and the steps required to correct the problem.

Thanks for your help in resolving this issue!


#2

Did you try the Teraterm from our website?


#3

Yes


#4

Bad cable?


#5

I have tried multiple cables, various USB ports and 3 different PC systems.


#6

the firmware file might be accidentally corrupted by choosing receiving file instead of sending file in tera term
Try to reinstall GHI SDK.


#7

The GHI SDK software was downloaded independently on the different PCs (eliminating the possibility of a corrupted file) but the software was uninstalled and then reinstalled just in case of an error in the installation process. The registering of the bytes as they were transferred would indicate that the send file command was used rather than recording 0 bytes if the receiving command was issued.


#8

The issue has been resolved and everything works correctly now. By the posted responses I received, I realized that the only software I had not independently tested or reinstalled was the Tera Term. After running a couple of tests on known hardware, I identified some multiple communication errors.

Thanks to everyone who helped!!!