Main Site Documentation

Firmware update problems


#1

I can’t seem to update firmware on my FEZ Panda II. Windows 7 (64 bit). SDK 1.0.15. Current FEZ Panda II version 1.0.5.0 - desired Version 1.0.6.0

I plug board into USB and device appears in Device Mgr as “Other | USBisi” (LED is flashing)
MFDeploy doesn’t see board under USB selection
TeraTerm Pro “Serial” option grayed out.
If I run USBizi Updater and perform steps 1-3 then press Update button I see a message that program can’t connect. I also observe that device USBizi device disappears and “Unknown device” appears in device mgr. LED is on solid.

I close all programs and unplug and replug USB connector and I’m back to Device Mgr showing USBizi device.

Then I right click on USBizi device and click "Update Driver"
I select this folder C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK and end up installing the GHI.NET Micro Framework USB Debugging Interface driver.
Device Mgr shows USBizi device is gone and new device is “Debuggable .Net Micro Framework Device.”

MFDeploy now works and I can check current version. (LED is flashing)
I run USBizi updater and execute steps 1-3. Device Mgr now shows .Net Micro Framework Device has disappeared and now COM9 is present as GHI Boot Loader Interface. LED is on solid again. I press the Update button and the updater still says it can’t connect to the device.
Since there is now a serial port I run TeraTerm Pro again but “Serial” is still grayed out.

What should I do now?


#2

I just stumbled across 64-bit drivers and installed them. Then updated the firmware using USBizi Updater and everything works!


#3

Great. Welcome here