Firmware update - again


Just bought the Panda II recently and have been searching through the Wiki, Forum for about one week without any solution to my problem…

Apparently the only thing on my Fez is the Bootloader. I tried to follow the update using the GHI Program but that fails every time, so I tried the TeraTerm solution ( I get the Panda II into “upload mode”, but when starting to transfer it fails every time. Sometimes it gets to 3%, other times it gets to 80% - it varies, but no matter how long I wait (up to 2 hours) it does not change.

Tried on 3 different machines, with 2 different cables. Same situation…

Is my Panda II fucked or the power from USB simply to low ?

Try with a wall wart connected

Tried with a 6V 2A power supply, same situation… I guess my Panda is toast…

I’m having the same issue with a FEZ Cobra - though the device was working fine for a few months up until some sort of event the other day. I can get into the boot loader with Teraterm but can’t get it to do anything after sending up the tinybooter.

Are you using the 1K blocks XMODEM setting when sending the file?

Also, you know that inside following directory is the GHI updater which will do the same thing. It may be worth a go to use that and see how she fares for ya:

C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\Firmware Update