Main Site Documentation

FEZmii board not recognized in Studio C# can't get robot to respond


#1

I can’t get anything working with the robot kit. the FEZmini doesn’t show up as an option in the Studio C# The spider hardware is an option.


#2

Start simple, remove FEZ Mini for the robot kit and only plug it to the PC using included USB cable.

What do you see in “device manager” on windows?


#3

I plug it in and nothing comes up on the PC but a led on the FEZmini board is dim and the ON light on the mother board lights up as ON


#4

What Gus is suggesting is remove mini from the “mother board” and try it that way.


#5

mother board removed little LED is on nothing from the PC indicating new hardware.


#6

Have you tried with another USB cable?

have you tried a different USB port?

Do you have a powered USB hub you can try?

Have you looked in the Device Manager?

What operating system?

What SDKs have you installed?


#7

I unplugged from one USB to another and then the hardware wizard found new hardware and installed GHI.NET Micro Framework USB debugging Interface .

I have windows XP with service pack 3

I have downloaded what I believe is the most current SDK from GHI website?


#8

Compare you version with the latest from release notes page

http://www.tinyclr.com/release-notes/

That way you will know for sure if you have the latest one.


#9

In the device manager I now see “Debuggable .Net Micro Framework Device” with “GHI .Net Micro Framework USB Debugging Interface” as a sub line below it.


#10

If you have the latest GHI SDK you are set to go.

If you need to update the firmware, there is an installer in the directory:

C:\Program Files\GHI Electronics\GHI NETMF v4.1 SDK\Firmware Update

When you install the GHI SDK, you will also be given an option to update your firmware at the end o the installation.


#11

I have the latest software and have installed it…should I install it again?


#12

I think you are OK. Try setting up a project for the mini and deploying it.

Have you seen the Beginners e-book in the Downloads section?


#13

Ok I will ry this. I’m starting the microsoft Visual C# now…


#14

are you reffering to beginners guide to NETMF?


#15

Yep, that is the one

http://www.ghielectronics.com/downloads/FEZ/Beginners%20guide%20to%20NETMF.pdf


#16

OK I’m lost now staring at the Studio C# program. I have selected a FEZ mini application but there doesn’t appear to be a window to program in and the term deploy is new to me.


#17

I have three windows: Solution Exploer, Properties and Error list and a large blank area that seems to need another window to work in…


#18

I get lots of errors like this:

Error 1 The type or namespace name ‘Hardware’ does not exist in the namespace ‘GHIElectronics.NETMF’ (are you missing an assembly reference?) C:\Documents and Settings\Curtis Marin\Local Settings\Application Data\Temporary Projects\FEZ Mini Application1\CodeFile1.cs 11 28 FEZ Mini Application1


#19

Visual Studio is huge. It would be hard to walk you through it in the forum. You need to invest some time and go through Microsoft’s documentation about Visual Studio or get a book. Here is the link to start with:

http://msdn.microsoft.com/en-us/library/ms165079.aspx


#20

Yes.

This is a MUST read for those getting started. It will lead you through the process.