Main Site Documentation

Fez Spider work with Micro Framewaork project,but can't work with gadgeteer project


#1

Hi.Yesterday I got some suggestions from here,for solving Fez spider deployment error.I created a new Micro Framework project and deploy it to fez,it was ok,it was working.but then i created gadgeteer project and tried to debug code to fez,it gave deployment error again.How i can sort it out?


#2

I bet you have one of 2 problems:

  1. You do not have the proper firmware loaded
  2. Your program has a tight loop not leaving any room for the debugger to latch.

I go for #1


#3

@ Gus - but I’ve checked it


#4

Are you using the beta SDK or the official release? Maybe your Gadgeteer project is using NETMF 4.1 or 4.3? You need 4.2 to match your device.


#5

@ Gus - I followed that website before : https://www.ghielectronics.com/support/netmf
and I downloaded “NETMF and Gadgeteer Package 2013 R1 Update-1” and “NETMF SDK 4.2 (RTM QFE2)”. and thats what i see


#6

Crazy right?! So lets try this, update the firmware anyways.

Also, when you make a Gadgeteer project, do not add anything, just the mainboard and in your code add to turn the LED on … mainboard.DebugLED … something something


#7

@ Gus - I’ve just tried but there was same error.During “there were deployment error ?” error i clicked “yes” then it gave “check you hardware” error and debugged to cart existent code which i created in Micro Framework project.


#8

How did you start the project? Select Spider in first step?

And I hope you already tried ot make a new project as the one you have maybe corrupted.


#9

@ Gus - yes i already select fez spider.and before i used that fez successfully,i created pulse oximeter project with bluetooth module,and it was working.But now it isn’t.I formatted my laptop and made it windows 8.1,i removed all programs and reinstall them but still i get error.and that fez give same error another Pc.


#10

@ Gus - i want to retun items.how can i do this? do you have any suggestion?


#11

@ Gus - i’ve solved it,i’ve changed my laptop’s region setting to USA.and it’s working now.


#12

I really do not see how this would be a hardware problem but you tried everything on the software side! You can return if you want but it has to be something simple we are overlooking!

What about starting a NETMF project and manually adding the Gadgeteer DLLs? Will it deploy then?


#13

Crazy! And how is that related to Gadgeteer?! What country you had it set to before?


#14

@ Gus - I think,it’s about .Net Framework’s problem.May be it’s associated with encodding of librarys which the sytem use.before it was setted Turkey.


#15

Aha, Turkey! We have had this problem for years, maybe 5 years! We were never able to determine what is the cause of it. This is the only country with this issue!


#16

@ Gus - Just Turkey,interesting.it was the last way that i could do,abruptly i thought about it.Also thank you very much for your attention :slight_smile:


#17

Look at this post from 3 years ago! https://www.ghielectronics.com/community/forum/topic?id=1405&page=3

I will buy some beer to whoever comes up with an answer to this!!! Maybe even a Margarita ;D


#18

Like Dah…the answer is pretty obvious…

Fez’s come from Turkey :whistle:


#19

Yes! Dahl! Lol that is the reason… you earn one beer :slight_smile:


#20

@ Gus - yes,maybe he solved the problem in a short time but it has taken me 3 days.Thats good idea! Preferring Margarita :slight_smile: