FEZ Spider won't connect to computer

I had the FEZ Spider connected and working not too long ago … but now the board will not connect to the computer. I keep receiving “USB device not recogonized” and no driver is loaded for the device under the Device Manager.

This is probably due to the fact that I was in MFDeploy and selected “Plug-in->Debug->Erase Firmware”.

Looking at how I should upload a new firmware states that the computer should recognize the board first and the use MFDeploy to load the new firmware. However, my computer will not recognize the board anymore.

I have used a dedicated power source and the USB cable as a power source but nothing seems to be working. I am connected to my computer through a powered USB hub.

I would like to load the same gadgeteer firmware that came installed on the Spider board, any suggestions?

Latest SDK comes with firmware loader application. Try to use it step by step and make sure you put switches in the right positions.

I also tried that and I receive “Cannot connect to the device! Follow steps 1 to 2”. FYI, that application (FEZSpiderMainboardUpdater.exe) looks great, but I need to resize the window since things do not fit nicely and I cannot … go tab control to get to the enxt steps!)

Did you try to connect FEZ Spider to PC directly? Don’t use USB HUB in this case.

Maybe I know why :)))

“… I am connected to my computer through a powered USB hub…”

Try to remove it, please. I am not sure but sometime the problem came from your USB hub.

no luck … i do have a second spider that works just fine with the powered usb hub!

does something special happen when you “erase firmware” on the spider?

While updating new firmware, make sure you put switches in the right positions, what did you see on your LCD after you release the reset button on FEZ Spider mainboard?

i can’t get to the point to update the firmware and i have tried the switches in the loader mode and the tinyboot mode as well to no avail, but i will certainly try again.

I’ll check what they lcd displays first thing monday.

I’ve tried the switches in the default, loader and tinybooter settings to no avail. Each time the computer does not recognize the device and does not load the drivers. I can uninstall the drivers from the computer and it will try to re-install the drivers but it fails each time.

The LCD screen displays all white, no text at all during any resets / power ons.

I have another spider board that works flawlessly …

Alright, so I did the same thing to my Spider to try and better help you, and had the same problems at first. Here are the steps that I took to get it working again.

  1. Set the switches on the board to what the updater says for “Loader” (Off,On,On,On)
  2. Make sure all instances of MFDeploy and the Updater are closed.
  3. Disconnect the USB cable and make sure it is plugged directly into your PC. We don’t want to trust a hub, that way we will know if there is a different problem.
  4. Reset the device
  5. Open Windows Device Manager, and you should see it listed under Ports as GHI Boot Loader Interface (COMXX) like the picture (your COM port may be different)
  6. Once you’ve made sure its there, you should be able to update and use your device again.

I hope this gets it working for you.

Thanks for taking the plunge and trying this out Steven! I tried your instructions but things did not work. I have attached a picture that shows what I see when I plug in the USB cable.

I can hit the reset button on the spider board and the device manager refreshes, but with the same error.

Just for reference, when I swap out spider boards and plug the USB cable into the same USB port that the [italic]bad[/italic] board is plugged into the drivers load just fine (attached picture) and I can work with this spider board as expected.

It should not say EMX, but GHI bootloader in the driver page. (picture 1)
You are trying to run the bootloader, so when you are seeing EMX, this is not correct.

I do not own a spider, but did you set the switches according to what Steven said?

The switches were set to the Loader position (Off, on, on, on) for the previous test … I also uninstalled the windows driver and connected the device again and it now says “Unknown Device” and listed under “Other devices”.

It stated “EMX” previously as I had tried to install the drivers when I was in Tinybooter mode.

What is the voltage on reset pin on EMX (pin 70)?

3.29 V (connected directly into the computer and through a powered USB hub)

Maybe you r serial drivers are not loaded properly.

Direct the driver installation to

C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers\GHI_Bootloader_Interface

or to this if above didn’t work

C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers\GHI_NETMF_Interface

it worked, I can now see the spider board! Now I need to update the firmware … will post back once that is successful! (I pointed the drivers to the first place Gus points out: C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers\GHI_Bootloader_Interface)

wow … I thought I tried pointing the drivers to the same place before, would the chip need to be in the Loader switch configuration (off, on, on, on) for the drivers to load?

thanks all!

I have just updated the firmware using the FEZSpiderMainboardUpdater.exe and everything works as expected!

Thanks everyone for the quick and accurate responses!

Hello, I am new to .NET Gadgeteer. I have the same problem with FEZ Spider. I have installed everything, last step was to update firmware, but it failed. I get error message “Cannot connect to the device! Follow steps 1 to 2 or visit … information to update manually.”

I use WIndows 7 x64.

When switches on board are set to “default” (off - off - off - off) and USB is connected, i get message “GHI .NET Micro Framework USB Debugging Interface installed”. When I set switches on the board to “loader” (off - on - on - on), press Reset button, in Windows Device Manager, under “Ports (COM & LPT)”, I see item “GHI Boot Loader Interface (COM29)”, but with warning icon - see attached file “DeviceManager.png”. When I try disconnect and reconnect USB, I get error message (see attached file “InstallFailed.png”). Device status in Device Manager is “This device cannot start. (Code 10)”.

I have no idea, what else should I try. Shall I try manual update from http://wiki.tinyclr.com/index.php?title=Firmware_Update_EMX ?

And a question - when I connect a display (T35) - should I see some information when booting? The display only shines, but there is no text, just nothing. Is it normal?

Thans for any idea
Lubos