Main Site Documentation

FEZ SPider sdk update problem


#1

Hello,

I have updated my FEZ spider with the SDK version 4.2.
I use the spider with a display T35 v1.3.
Unfortunatly, since I installed the new version I A error message that appears.
“The debugger engine failed to receive any debug events from the debugging target”

My code is still the same… just a new version of the SDK + GLIDE (sdk =4.2 and glide 1.0.7)
Windows 7 or windows 8.1 send the same problem. I use VS2012 .
I have tried with a new project and the result is always the same. Sometime the debugger work and sometime the debugger display this error message…

That is why I wanted to reinstall version 4.1 and now my spider display …
"main exited !!??? Halted CPU"
What can I do ?

Thank you for your help


#2

First up, make sure if you went back to 4.1 that you also went back to timybooter that matches.

If you have code that does not do a thread.sleep(timeout.infinite) at the end of main() then you’ll get that ‘exited’ message. Add the sleep or fix the app logic to keep running and that message will go away.

Now onto 4.2 and debugger. If you don’t give your app time to sleep, the debugger connection can be intermittent so if your app has a tight loop, adding thread sleep for 5 or so will help. Remember that 4.2 bought a driver change, which is also possibly related to the change you see. But my first thought is free up time in your app to allow debugger thread to connect


#3

Well,

In my case the problem is almost solved.

I explain :
I create a empty Gadegeeter project
I use a FEZ Spider + Display T35 + Multicolor Led (slot 9 or 6)
When I try to debug via VS2012 I have this message : “The debugger engine failed to receive any debug events from the debugging target”.

When I use
I use a FEZ Spider + Display T35 or
I use a FEZ Spider + Display T35 + Multicolor Led. + SD card or another modules
The system works.

I dont know why, but it’s seems, when I use the multicolor LED module alone I have this problem.

My config :
Fezspider+T35 ver 1.3
TinyBooter version 4.2.11.1
TinyCLR 4.2.11.2
.net microframework 4.2
VS 2012 ultimate
window 7 or windows 8

In my application, I use 2 timers (250ms and 300ms) and 1 thread (main loop) . I don’t see difference, if I have a

 or not in my main loop. 

Currently, this message appears often not. In this case I cut the power on and I redo the manipulation on the FezSpider again. It works well.