Main Site Documentation

FEZ Spider Not Showing Up in Device Manager


#1

Hello all,

I bought my kit the first day pre-orders were available. When I got it, I tried running it on my MacBook Pro through VMWare and could not get it to work, so I thought maybe it was an issue going through VMWare on my mac, and that I would try it directly on my PC. Well I am finally getting around to trying it on my PC and I am unable to get the device to even be displayed in Device Manager (I don’t have any unrecognized devices and no Ports). Details below.

My system:
Dell XPS 8300
Core i7 2600 3.4GHz (8 core)
16GB RAM
Windows 7 64-bit
All software up to date

I already had VS2010 Ultimate installed, installed everything else from the latest download, in order (just did it this morning).

FEZ Spider setup:
Set jump switches to loader mode (off, on, on, on)
Red power module connected through USB directly to PC, that connected to main board, with LCD connected too.
The LCD shows:
EMX
Version: 4.1.6.0
Debug: COM1
LCD: 320x240
IP: 192.168.1.200
MAC: 00.1A.F1.00.42.0D
Managed heap size: 13631488
Custom heap size: 1048576

Waiting for debug commands…

I then run the FEZ Spider Mainboard Updater and I always get the message “Cannot connect to the device! Follow steps 1 to 2.”

I have tried multiple USB cords, and every USB port on the box. My hunch is that there is a hardware issue, as a device is never displayed (even unrecognized) in device manager. Scans for new hardware show up blank as well. I should add, the issues I was having on my MacBook Pro through VMWare were the same, and I assumed USB and driver issues at the time, but have now tried on the PC too.

I have read through the other threads I have been able to find, but reading through and trying to do applicable suggestions haven’t worked so far.

I do not have other FEZ boards where I could test them, this is my first kit. I am much more a software guy, but hoping to do some fun stuff with the kit!

I am attaching a picture of how I have it setup.

Any thoughts?


#2

From the image posted I can tell that you were holding FEZ Spider up side down when you changed the switch positions. The screen becomes white when you enter the bootloader mode.


#3

WOW, that’s embarrassing :-[ You were right it was upside down, turned it over and it worked like a charm, thanks Joe!


#4

Haha we all make these mistakes, especially when there is a new board and excitement in the air :slight_smile:

Enjoy and welcome to the community.