Main Site Documentation

FEZ Spider motherboard not recognized in device manager, when put in bootloader mode


#1

Hello all,

I want to update my FEZ Spider from .NETMF 4.1 to .NETMF 4.2;
But for that, it seems I have to update my boot loader too. For that, I’m following the instructions as described (putting the switches to bootloader mode: off/on/on/on - pressed the reset button…)

The problem is that as soon as I press reset and my board is in bootload mode, I get an unrecognized USB device warning.
And when looking in Device Manager, the device is visualized as Unknown USG Device (Configuration Descriptor Request Failed). Updating the drivers doesn’t seem possible

I don’t see a Ports section neither.

Any idea what could be the reason for this ?

Best regards


#2

Hi Sam,

First up, make sure that you set the switches when the devise is disconnected and not powered up, and then when you plug it in it should load up into bootloader mode. The error about not getting descriptors is typically only seen when it doesn’t boot cleanly into a specific mode.

Good luck!


#3

Hello Brett,

Thanks for the fast reply (in general community looks very reactive around NETMF & Gadgeteer > cool!).

Unfortunately, it still doesn’t work out. I set the jumpers prior to booting and still the device comes up as an unrecognized device in device manager with the description I mentioned in my first post.

I tried updating the drivers manually (adding hardware manually, etc), but still to no avail.

I have a Windows 8.1 x64 machine and am using a USB 3.0 port.

Would you have other suggestions ?

(PS: the description in FEZ Config mentions that you first have to have the device connected to USB & powered up, before you change the switches. I added a screenshot of the wizard)


#4

I found another post indicating that it might be because of USB3.0, to which the GHI Boot Loader Interface might be incompatible:
https://www.ghielectronics.com/community/forum/topic?id=10960.

The problem is my laptop only has 3.0 ports. So, I might have to try the update on an older laptop. I’ll update this post, if it fixed my problem


#5

Do you have a USB hub? That’s usually a USB2 device and may improve your chances without having to get the older machine up and working…


#6

Good catch and yes - I tried that one, but still the same behavior.
Will try with my old laptop, this afternoon


#7

I tried it on my “old” laptop and got it working in less than 5 minutes!
So, it was the USB2.0 vs USB3.0, I believe.

Thanks for the help, running NETMF 4.2 now.