FEZ Spider Mainboard Updater doesn't work

I have built a Board with “EMX Module” and the layout is on the basis of “FEZ Cobra”.(picture 1)

I want to updata the “EMX Module”, when I use the board first time, but fortunately it doesn’t work. it shows me always “Cannot connect to the device! Follow steps 1 to 2”.(picture 2)

I have checked the “hardware Manager”, my computer has found the USB interface of the board.(picture 3)

Can you help me? how can I update my board?

Have you tried the EMX updater rather than the Spider updater?

You are using the updater for the Spider. Try using the EMX updater.

where are the 3 buttons “UP”, “SELECT” and “DOWN” on the “EMX Updater”?

should choose the option “Gadgeteer Mainboard”?

Check the Cobra schematic, upon which your board is based, to see which module pins the buttons are attached.

Also, read http://www.ghielectronics.com/downloads/EMX/EMX_Broch_Pinout.pdf and http://www.ghielectronics.com/downloads/EMX/EMX_User_Manual.pdf.

@ Mike -

Should choose the option “Gadgeteer Mainboard”, when I updata my board?

Not unless you have built a Gadgeteer mainboard.

@ workhard10 - Since your design is based on the Cobra then you should use the EMX Updater.
For up, down and select you will need to short IO4 (pin 7), IO30 (pin 53) and IO0 (pin 3) to GND, then pin 70 for reset

I have tried the “EMX Updater” for my board and it works successfully!!!

thank you!!!

Super :slight_smile:

That is one huge board, nice :slight_smile:

Please try manual update first.

1 Like