Main Site Documentation

FEZ Project Templates not showing up in Visual Studio 2010 Professional SP1


#1

I installed Visual Studio 2010 Professional for free through Microsoft’s Dreamspark program, and applied the SP1 update. I then installed the .NET MF and the GHI SDK.

However, when I run Visual studio, the FEZ project templates do not show up in the list of new project types.

The GHI assemblies [italic]do[/italic] appear to be integrated into visual studio

[line]

There are a couple of things that I feel may have caused this. Firstly, there were two installation files in the GHI SDK. I have no idea which one I was supposed to run, and do not remember which one I did. However, the C:\Program Files\GHI Electronics\GHI NETMF v4.1 SDK is suitably populated, so it seems to be installed.
Secondly, the SDK was installed on an administrator account, but I am running Visual Studio on a different limited user account.

Where are the GHI templates for visual studio stored?


#2

Please see this:
http://www.tinyclr.com/forum/1/3072/


#3

I’ve heard that netmf SDK isn’t supported with VS SP1 - not sure there are issues, but there could be. Don’t discount that if you see any other issues…

Mike, can you look to make the GHI installer give the “all users” option you see in some other installers? That might also make this problem go away…


#4

I have the project templates in VS2010 SP1. However, the problem is that after creating the project, VS2010 SP1 can’t open it. In addition, it cannot open my solution that was previously working in VS2010 non-SP1.


#5

running 2010 SP1 Ultimate…no problem opening the templates here…Can you give more details of your system? Operating System, etc.


#6

Have you ever switched between C# Express and the full (Pro or Ultimate) version of VS, maybe on another computer? I had problems like you describe bouncing between the two, particularly opening projects created in full version on the express machine. Neither had SP1, however. Fortunately, I had enough licenses to bag Express and go to Pro.


#7

I have a similar problem.
After moving from Express to Ultimate (complete removal / reinstall), Gadgeteer is no longer a solution option; just the standard GHI project templates.
Also, VS 2010 Ultimate desn’t recognize the projects I created in VS 2010 Express (possibly due to the lack of Gadgeteer info?)


#8

Re-install the GHI SDK.


#9

Thanx - I already did.
I removed the whole bit, rebooted, then reinstalled it according to http://www.tinyclr.com/support/ except I replaced Visual C# Express with Visual Studio 2010 Ultimate.
The weird part is that I installed on my work computer (Spider travels nicely in my laptop backpack) and I have the Gadgeteer templates, etc. there and functional.

I looked at the templates foloder on both and they’re identical - where do the Gadgeteer components get dropped?


#10

Is it “english” windows with “english” VS2010?


#11

Yep; US-EN all the way through.

I finally fixed it - it seems the Microsoft GHI .NET Gadgeteer Core wasn’t getting removed properly, so I walked the installed programs list looking for anything remotely related to GHI, removed it, then used the Gadgeterr installer package to put everything back.

Thx for the responses, tho!
Now back to my WPAD 'speriments…
;D