FEZ Panda II MODE pin, jumper to enable USB client

In order to enable the USB client, I need to configure my Panda II to use serial debugging (even though I’m not actually using debugging at all). The beginners guide mentions jumpering the MODE jumper (or LMODE pin) to 3.3V, but it does not mention the Panda II and what pin should be used / connected to what.

How do I select serial debugging on the Panda II?


It is basically whatever text we could fit on the board.

Ah, thanks. That answered another question as well, namely, “can I power the board through the 5V pin?” The answer is, yes, definitely :slight_smile:

Oh, and the pin should simply be jumpered to a 3v3 pin, correct?

And, while we’re at it, powering the board through the 5v pin will result in the correct 3.3v showing up at the correct pins, right?

Do not Jumper 3.3V to 5V.

Simply push 5V to 5V.

3.3V comes from an LDO Vreg connected to 5V, so yes, it will “just appear in the right spot”.

Supplying your own 5v supply basically bypasses the 5v regulator, this will still give power to the 3.3v regulator though.

By that I meant the MOD (LMODE) pin should be jumpered to a 3v3 pin to enable serial debugging on bootup.

No to ground. This is why we put MOD next to GND :slight_smile:

Ooh, that makes lots of sense :slight_smile:

Do you guys make FEZ Panda II schematics available to community?


So could I get some instructions for a Newbie to use USB client without debugging. I have no rs232 shield.
I am on FEZ PANDA 2

  1. Program is installed by debugger. My program waits to get out of usbdebugger mode
    here is code snippet
    public static void Main()
    OutputPort led = new OutputPort((Cpu.Pin)FEZ_Pin.Digital.Di51, true);

          while (Configuration.DebugInterface.GetCurrent() ==
         // Start CDC
         USBC_CDC cdc = USBClientController.StandardDevices.StartCDC();

  1. I put 1k resistor between mode and ground, and 1k resistor between com rx and 3v3.

  2. I reset by pressing loader /reset [ or by using watchdog feature]

My program runs its usb stuff…

[now when I want to debug again I just remove connector between mode and ground
and again press loader/reset]

OK and this is where I am confused… I feel I have to unplug the usb connection for the serial port to be recognised, but I haven’t quite worked it out… I go through some random cycle of resetting / unplugging and eventually teraterm recognises the serial link.

would value a clear explanation of what i need to do to get the CDC serial port to be recognised by my PC.