Main Site Documentation

FEZ Panda II; did I smoke pin 53?


#1

I was messing with my FEZ trying to get the button connected to I/O pin 53. The first time I deployed, things went OK.

I then changed the program to place a pulldown flag (instead of the pullup) so that I could see if there was any differences. When I deployed, I got some weird errors during the ‘linking’ portion where it told me that I was using .NET 4.2 when I had things set to .NET 4.1. I then noticed that the LED was on solid (and not as bright as it normally is). I reverted to the working code . . . still no linking success.

I took the board into work and connected it to my work machine. The linking functioned fine, but the LED is still on solid. Pressing the button on to change the state of the LED does nothing.

When I measure across the switch, pressing the button does ground across the switch, so the switch is working.

Measuring the voltage at the junction of R1 and R22 shows a steady 2.05V which doesn’t change when the button is pressed.

Any clue as to what I may have done? Changing the internal pullup/pulldown shouldn’t cause this.

Also, has anyone ever replaced the processor on their FEZ before? Does GHI offer repair or replacement?

Thanks all!


#2

Welcome to the forum!

Replacing MCU? Yes, people did this before. I remember there was somebody who did it, but it was long time ago. You can try searching the forum.

Did you try uploading default app that just blinks the led?


#3

@ Architect - Hey Architect . . . I see you are an avid replier on the forum.

I did reload the blinking algorithm and same result . . . solid LED.

Funny thing is the LED is dimmer than normal, so the processor must be sinking quite a bit of current.


#4

Check voltages out of VRegs just in case.


#5

Welcome Slappedhard

Yep you can buy 1-off USBizi100 chips from GHI and replace them.

Whether you actually have fried a pin, I can’t tell - but to me it doesn’t sound like something you should have done as long as you’re only drawing the correct amount of current via your LED. These chips are sensitive to over-current, so you do have to be careful; you’re always better off using a transistor to drive the LED.

One thought, I remember the last person who fried the chip actually found the CPU got extremely hot and would not respond, wouldn’t show up as a USB device when connected to the PC, so you’re somewhat better off. First up I would change your LED blinking example to the onboard LED


#6

Either I’m rich or extremely lazy… but I don’t think I’d spend the time removing and replacing a 100 pin IC that costs $17 on a board I can buy for $40.


#7

@ Architect - I am running the Vcc off of the USB port. When I measure the 3.3V regulator, I get 3.31V. The 5V regulator is not being used.

The 5V looks to be only 4.8V.

Looking at the USB port information in DEVICE MANAGER, I see that my Panda is sourcing 280 mA from the USB port . . . that seems like a lot. I think have am going to remove R1 to disconnect the power from Vcc on the LED and see how much the current drops; although if it indeed floating high (pin 53) then it may be sourcing current through the LED to ground.


#8

You may have already looked this up, but active power consumption is spec’d at 103ma.


#9

@ FireyFate - The 280 mA is the complete board . . . so it is including the oscillator and voltage regulators and chip. I agree though, still seems to be a bit high.


#10

Well, lifted pin 53 and the chip is still pulling high current. I am not going to play with it much more . . . ordered a new one to play with. Will have to be careful with the second one.


#11

That’s what I mean… the Fez Panda II product description says 103ma active for the board. I’ve never measured it myself though. Enjoy your new Panda… and the way I see it is if we aren’t destroying something now and then we aren’t really trying!


#12

Everyone, got my new Panda II board last night. Plugged it in and found that it is also pulling 280 mA of current from the USB input.

The way that I check it is:

  1. Plug the Panda II into the computer using the USB cable.
  2. Open the Device Manager by right clicking on My Computer and selecting Properties
  3. Select Universal Serial Bus Controllers
  4. Right click on each of the Generic USB Hub and select the Power tab.

A USB port can only source 500 mA of current. I have only seen one instant where I received an USB to serial converter card that had the 5V USB line shorted to ground. MS Windows was actually smart enough to detect the large current draw and shutdown the port to protect my computer.

It would be nice if we could compile a list of standard current draws through the USB port for each product.


#13

I’ll try that on my Panda II sometime soon… I’m suspicious of how accurate that reading is. I’ve never heard of anybody calibrating their USB ports :wink:


#14

Looks like my Panda was not damaged . . . what happened was the GHIElectronics.NETMF.FEZ file was corrupted and some of the output pins were weakly being pulled up or pulled down based on the voltage I was reading on them.

I removed and reinstalled everything and things are working correctly again. Looks like I may have a hard drive that is having SMART recorded issues.

Well, at least I have two working Panda boards, so one will stay home and the other at work to play with at lunch.

Thanks for all the inputs and suggestions. This is a very comfortable forum to share on.


#15

Good to hear!