Main Site Documentation

Fez Panda cannot connect to the device error


#1

I recently received Fez Panda, followed TinyCLR download directions, installed C# 2010, Framework 4.1 and GHI components.

Plugged Fez Panda to USB (Windows XP) and tried to deployed Fez Panda basic LED program and got connection issue.

Tried USBiziUpdater and got following :

– Log –
Connecting to device…
Cannot connect to the device! Follow steps 1 to 3

I disconnected Fez Panda, followed steps 1 to 3 and 4 and got same connection error.

Appreciate some assistance.


#2

What do you see in device manager when panda is connected?


#3

Debuggable .Net Micro Framework Device will pop in and out, will not stay (see attached file)

Looks like there is a slight play when connecting USB cable to Fez Panda USB port, it is not quite snug.

When slightly wriggling cable, the device manager will show the Debuggable .Net Micro Framework Device and then dissapear.

I tried this on several USB ports and even on another computer with the same software installed.


#4

Have you tried another USB cable?


#5

Yes, I have tried another USB cable and also unplugged and plugged back the cable and Fez Panda several times.

The power pin seems to be providnig power as the LED on the Fez Panda is blinking.

Not sure if this is a hardware related issue with the Fez Panda USB connector.


#6

So the device is running. But maybe the updater is failing fro some reason. Have you tried to run the updater with admin privileges?


#7

I am logging in as admin in XP and had no problem installing other USB devices such as webcam, printer, mp3 player, Kindle, etc…

I don’t think it’s the updater as I earlier mention that the Fez Panda in device manger does not seem to stay connected.

When I wriggle USB cable it will show up for a few seconds then disappear.

Excited and sad at the same time that I cannot try out my new Fez Panda.


#8

I think we should try to get the firmware re-loaded. Did you ever do that, and did this device ever work?

So step 1 I would suggest is inserting the USB cable from the Panda while having Device Manager open. Then, reset the device while holding the LDR button down.

You should then see the “GHI Boot Loader Interface (COMxx)” in the “Ports” section of device manager.

You should then use the USBizi updater and get the latest firmware onto your device.

Then, after appropriate resets, we’re hoping to see the Debuggable .NETMF device listed and staying there.

Then you can open MFDeploy and see what devices you can see. You should see on USB a USBizi_USBizi device listed and it should respond to pinging.

hope this makes some progress ! :slight_smile:


#9

Maybe you have a bad USB cable?

Do you want to call us and we will step you through it?


#10

Thanks Brett and Gus.

I will try Brett suggestions.

I am in LA, west coast, and currently not at my workstation at home.

Gus, what number do I call? I can call tomorrow morning 7AM west cost time if this is ok?


#11

The number on GHI’s “contact us page”. We are eastern time.


#12

Thanks Gus your help in troubleshooting my Fez Panda connection issue.

I changed the USB cable, in device manager held down the LDR button for several seconds and the USBizi device appeared.

You then led me through MFDEPLOY to verify that the device is connected and recognized by my PC.

Forums are nice to get help but it really makes a big difference to talk to a KNOWLEDGEABLE person, which many business lacks now a days.

Go GHI!