Hi All,

I have experience working with LPC16xx and LPC23xx families but I thought I’d see what FEZ was all about.

I think my FEZ Mini is DOA. I tried plugging it in to my PC and nothing enumerated. I attempted the same thing with the LDR button pressed and I got nothing again.
Is there something I need to do before I can start using the FEZ? A jumper or firmware perhaps?
I can’t see anything in MFDeploy. I can’t see the device on any other PC or OS either.
I’ve searched forums and manuals but I can’t find a solution.

I have the development environment installed and working without any problems.



Welcome Kev! Did you install item #4 from the Support page. Mini is a 4.1 device.

Yes I did.
I already had VS Professional 2010 installed.
I followed steps 2, 3 and 4 in order.

I can create and build projects but I can’t attach to the FEZ Mini.

One thing I’ve noticed between my first post and now is that there is mention of a demo project that is loaded on FEZ Mini’s during production /testing stage (is this correct?). When powered, the LED on my FEZ Mini glows faintly. I’m not sure if that tells you anything.

Do you see anything under device manager?

No. Nothing is appearing.
I also checked using Windows PowerShell:

gwmi Win32_USBControllerDevice |%{[wmi]($_.Dependent)} | Sort Description,DeviceID | ft Description,DeviceID -auto

Still, nothing.

What is the expected VID and PID?

(Thanks for the prompt replies guys)

Last thing to check, try different USB cable and plug directly, no hubs.

If nothing, contact GHI directly for RMA please.

Welcome to the community.

Perhaps try it on another PC. What OS are you using by the way?

Definitely nothing. I’ve tried 4 machines all with different leads.

When contacting GHI, please include a link to this thread.

Thanks guys. I’ve sent off a return authorization with a link to this thread.
You’ve been great.