Main Site Documentation

FEZ mini bricked, what to do?


#1

Hello,

I just received a FEZ mini and was trying to update the firmware for the first time. In TeraTerm I accidently used send file instead of XMODEM transfer and it completely bricked my FEZ. Now I am unable to access the bootloader and the serial interface does not respond to any commands. Is there any hope of salvaging it? I cannot access the bootloader and it no longer will respond to pings from MFDeploy, although it does still show up as COM3 when it’s plugged in. Is there any way to reprogram it still or am I out of luck? Thanks for any suggestions.

elitedev.


#2

I had the same issue when I got my first Domino.
The ting to do is to restart the board with the LDR button pressed so you get the virtual COM port. Then upload the firmware again. You might have to try some times. Even download a fresh version of the firmware (as many has overwritten with receive instead of send).
don’t panic, your mini will be fine :slight_smile:


#3

BigPilot had a similar issue when he sent file instead of using XMODEM. He used a different client.

http://www.tinyclr.com/forum/2/962/


#4

You only need to reload the firmware and it will be fine.

It should be in loader mode with virtual COM port and it should be responding tot eh loader commands.


#5

The problem is that I will hold LDR button down. It comes up GHI Bootloader Interface on COM4. I use TeraTerm and open COM4 and it doesn’t do anything. It doesn’t respond to any commands and just sits there with a blinking cursor. I think the Bootloader has been erased or corrupted, I don’t know how to upload the firmware if it does not respond to any commands. I’ve tried many times to plug it in and out and hold and not hold button, but nothing helps. It just sits there dead. Any other suggestions?


#6

It is impossible to erase the loader plus windows sees a virtual serial device from USB so the loader is working.

Reset your pc and try again.
Make sure your board is really com4


#7

Alright, I have tried many things. Even using another computer. I’m sure the com port is right. The weird thing is that no matter if I hold the LDR button, it will come up as the bootloader interface. When I disconnect the FEZ, it freezes the computer. It does that on both computers I tried it on. No matter what I do, there is no response in the terminal. No matter what I type it doesn’t do anything even though it worked before I messed up. It’s a shame that I managed to kill it before I even used it. I’m pretty sure it’s dead and there isn’t anything I can do to fix it.


#8

EliteDev, don’t give up yet ! We’re here to help (I hope we can !)

Can I ask about what USB cable you’re using? Do you have another cable around you could try as well? When you tried it on the other PC did you take the cable with you?

Some of this sounds like your drivers on your PCs might actually be screwed up too. What OS are you using? II’d try going into Device Manager and use that to uninstall all the drivers, then reinstall them.


#9

I appreciate your help.

I have tried other cables, that I know work. I use it to connect my mbed and digital camera and it works fine. I have reinstalled the driver, including installing it on more then one computer. Still no joy. I know the driver itself works, because I had no problem accessing the bootloader to update the firmware the first time. The problem is that when I accidently clicked send file (not XMODEM send) it started to send the file serially and instead of uploading the data it started executing commands on the bootloader that it prolly shouldn’t have.

I might sound like a n00b becuase I messed up the firmware, but I am very knowledgeable in computers and using uC’s. I’m pretty certain there is an issue that is not related to my computer, cables, or drivers. I was tired and got cocky and didn’t read the guide before I started clicking and thats my fault.

Is there anywhere I can send this unit to have it checked or repaired?


#10

Can you jump into chat please? I will try to help you one-on-one


#11

Alright, I’m in chat.
Thank you.