Main Site Documentation

FEZ Medusa obsolete?


#1

Hi,

I finally got around to getting a usb thing that may (fingers crossed) make the Medusa work with my laptop, so I came here looking for files and documentation and found a big red OBSOLETE tag on them–what implications does this have? Can all the modules I got via the Kickstarter work with another board? Where are the downloads for the Medusa now? What kind of support can I expect for it, etc?


#2

@ spongefile - The documentation is still correct most likely:

https://www.ghielectronics.com/docs/215/fez-medusa-family

A lot of us have it and we can help you if you have specific questions.


#3

You can find the obsolete documents here:

https://www.ghielectronics.com/docs/search?q=medusa&showObsolete=1

GHI officially doesn’t support the product anymore but you should still be able to get community support via these forums. However, it’s just an Arduino board. So, you can also get general assistance all over the Internet.


#4

@ spongefile - Here is the link for the Medusa SDK source code:

https://bitbucket.org/ghi_elect/gadgeteering/src


#5

That was quick, guys, thanks–the USB dongle has fixed my serial problem, but when I try to compile I now get this error:

arm-none-eabi-g++: error: unrecognized argument in option '-mcpu=atmega328p

this line is of course in boards.txt. Wondering now if I have the wrong Arduino IDE version…


#6

What IDE version do you have?


#7

1.5.7


#8

@ spongefile - Something wrong with your settings. Medusa is an AVR base board, but you are using arm compiler. Make sure you edit original boards.txt file and use the content from boards.txt on GHI’s bitbucket. You will also need the bootloader files from bitbucket copied to the proper location in your Arduino installation tree.


#9

Ok! Solved that problem. Now I’ve been googling/trying stuff out all day, but stuck here:

Where does gadgeteering.h go so the IDE can find it? The bitbucket readme just says it’s “to be included”.

Knowing where the other stuff should go would also be helpful. I’ve figured out many of them via trial and error, but not everything.


#10

@ spongefile - You need to put whole Gadgetering folder and its contents into your “My documents”/Arduino/libraries folder

You can also put Tests and its contents into the “My documents”/Arduino


#11

Really sorry to keep hassling you guys about this, but I’d love to get this board to work–everything else after this seems so clear.

Tried both putting it into the package contents (as I usually do with other libraries) and in the documents/Arduino/libraries folder, but gadgeteer.h still doesn’t get found. Note: I’m using a Mac, so procedure may be different. Here it is in the package contents–renamed the original unzipped folder to “Gadgeteer”, perhaps that’s the issue?

Error message:

In file included from Button.ino:21:0:
/Users/tina/Documents/Arduino/sketches/libraries/Modules/Button.h:19:29: fatal error: …/Gadgeteering.h: No such file or directory
#include “…/Gadgeteering.h”

#################################################

EDIT: Fixed above by making a libraries folder in my sketches folder and putting Gadgeteering there. However, now I get this:

In file included from Button.ino:18:0:
/Users/tina/Documents/Arduino/sketches/libraries/FEZMedusa/FEZMedusa.h:20:41: fatal error: …/Gadgeteering/Mainboard.hpp: No such file or directory
#include “…/Gadgeteering/Mainboard.hpp”

Which is of course because FezMedusa.h contains the following:

#include “…/Gadgeteering/Mainboard.hpp”
#include “…/Gadgeteering/Socket.hpp”
#include “…/IO60P16/IO60P16.h”
#include “…/Gadgeteering/SPIDevice.hpp”
#include “…/Gadgeteering/I2CBus.hpp”

However, I can’t find these files anywhere.

My only noob theory:

FEZMedusa12.h exists in Mainboards, but not in boards.txt. Did the FEZMedusa12.x files replace FEZMedusa.x at some point?


#12

My MacBook is dead, so not much help here. May be somebody else can share their working layout.


#13

@ spongefile - We never did fully support or test Macs before the Medusa line was discontinued. That said, things should work the same there.

It looks like your code might be a bit out of date. I would download the source from the repository Architect linked at the SDK-R1-BETA tag. Take a look at the https://bitbucket.org/ghi_elect/gadgeteering/src/262ae1747db047a59313db6b9e128ac49209e915/Dist/Windows%20Installer/Application%20Folder/Arduino.zip?at=SDK-R1-BETA file. That is everything we install for Arduino support. You can try to mirror that directory structure wherever your Arduino needs it to be on your platform. The ButtonLED example inside should show you the basic structure required.

I believe we only supported the 1.5.5 beta of the IDE at the time we released this SDK. The current 1.5.8 may work, but we have not tested it. I do not think 1.0.6 either.