Main Site Documentation

Fez Hyrda & SD Card issue


#1

Hello

I am having an issue with a SD reader on a FEZ hydra. No matter what I do, my card does not seem to mount. To make it as simple as possible, I used the basic SD test code from http://www.tinyclr.com/codeshare/entry/643. I have also tried the sample code from http://wiki.tinyclr.com/index.php?title=SD_Card_Module.

I see in the debugger that it is trying to mount, however I get the “SDCard ERROR : Unable to mount SD card. Is card formatted as FAT32?”. Here’s the different things I’ve tried:

  1. Using multiple SD cards, a Sandisk 1 GB, and a ATP 8GB.
  2. Unhook all other devices
  3. Power from both USB & AC
  4. Change from ethernet firmare (the one I normally use) to non-ethernet.

My hydra also gets the abort error when deploying to it (and it is not recognized as a USB device) about every 10th deploy, and I have to re-flash the firmware. For this, I use the SD card method to load boot.bin, which works! So, the SD card seems to be able to connect then.

Thanks in advance.


#2

OK I have an update on the issue. I also have an Argon R1 mainboard, and when I try the same SD test with the 8GB card, it works.

So, how can I determine what is going on with the FEZ Hydra? Is this a damaged board or another issue?

Thanks


#3

Only 8Gb works on Argon or all of them?


#4

The 8gb only works on the Argon.


#5

What is your SD card part number and where did you buy it from? Maybe we can get this card and test it for you.


#6

Hi Gus

The 8GB that does work for me is the ATP 8GB (AF8GSD). Please see http://www.memoryten.com/pc/005267/Flash-SD-SDHC-8GB/

However, I am wondering if my Hydra is the issue, as I am running into a few errors that I dont think I should be:

  1. This SD error
  2. I have to re-flash the device approx. every 10 deployments, as it gets in an error state and it cant be seen by the PC until I flash the boot loader.
  3. When I attach a TE35 and wire up a touch event handler, I find that I only see a touch event fired every 10 or so touches.

Is there a utility that I can run to test the hydra device?

Thanks


#7

1 and 2 can be related to not having sufficient power. Are you using powered hub?

as for 3, that is a known issue which has been fixed and an update will be released in very near future.


#8

Not using a powered hub, however the DP module is being used, and i am hooked into 9v 500ma power at the same time. Will this replace the need for a powered hub?


#9

Yes you do not need power hub if you have power pack.


#10

Gus

Based upon your feedback regarding power, I decided to test another power module (a Love electronics USB DC Power). I ran the same SD card test, and it also failed.

So, I dont think it is a power issue - and I am leaning further to an issue with the mainboard. Is there any tests I could run?

I also have attached a photo of the error message I receive when I am forced to re-flash the hydra.


#11

we had another person reporting an ABORT error on a device, and the way that was addressed was by reapplying the firmware. Not saying that yours is the same, but could you give that a(nother) try ? Include the bootloader too…


#12

Hi Brett

Thanks, every time this happens I have to re-apply the firmware. I have probably gone through that process 15 times now, and it works for another 10 or so deployments from VS.NET, and then randomly it happens again. Getting frustrating to say the least :slight_smile:


#13

These strange behaviors are typically tied to the power source.