FEZ hydra update failed

Hi,

I just received my FEZ Hydra which is my first .Netmf device.
Went through the first tutorial after downloading all the software on the download page.

Problem is, when running the update tool for 4.2 , the board was not responding after reset.
Now the software doesn’t even manage to connect to the board.

I don’t have any SD card smaller than 2GB and I’m not very tempted by putting wires (that I don’t have actually) between pins to clear it.

What should I do now ?

Thanks, Thomas

Welcome to the forum!

Can you please take screenshot of the updater window only? It is hard to see.

Hi, here is a bigger view
Goes without saying that I tried to reset the board and the PC, but the problem is still the same

When you connect the board to the PC does it appear in the DeviceManager?

Unfortunately it appears as an Unknown Device

Try to reinstall the driver and plug it to a different USB port.

Actually, I am trying to reinstall everything because I guess taking the Beta package (number 3 on that page http://www.ghielectronics.com/support/dotnet-micro-framework ) was probaby a mistake.
I uninstall everything on my computer and I am starting again from the beginning.
Which packages should I download if I want everything for the Hydra to work ?

Thanks

Hi thomas, yesterday I also received my Hydra and I reinstalled step 2 and 3 from http://www.ghielectronics.com/support/dotnet-micro-framework

First remove all software starting with “GHI”, then remove Microsoft .NET Micro Framework 4.2 QFE2 SDK. After that restart your computer and follow the steps.

I did have the drivers working, but I had issues that the Hydra updater tool didn’t find the correct hex files and crashed. It worked out that I also had to install the “Optional” package from step 4.

Just to say, you should get it working, even thoug it says “beta” :slight_smile:

3 should be fine. That is where latest 4.2 is.

I’ve reinstalled everything but it still doesn’t connect to the board.
Nothing appears in the WIndows device manager.

NB: We’ve tried with the cerberus of a friend and his board is detected by windows.

Do you have SD module?

If you boot into bootloader mode, you should see the device as a serial port; that should not require the GHI driver. So if you can get it to recognise that, that’s a good step forward.

I do have a SD card reader but no SD card under 2GB.
I guess I’m buying one then.

Not just a reader. SD module for Gadgeteer.

SD card is one of option, there are 2 another options. Here is one of them:

  • Connect pin 8 to pin 10 (GND) on socket 3, power up Hydra.
  • After 5 seconds, disconnect wire between pin 8 and pin 10.
  • Check under Device Manger, make sure there is a new COM port created.
    Now, you can use Hydra Updater or use update manually. Please note if you are going Hydra Updater, always use external power

He mentioned he is not comfortable connecting wires.

Okay, I ordered a 1gb sd card yesterday and by “reader” I meant a Gadgeeter SD module.
I’ll try to find correct sized wires to do this, but I’m not sure where to find them, maybe seeedstudio.
Also I thought that powering the hydra using external source was not mandatory.

If I can make a suggestion to guys at GHI, specifying on the shop page of the Hydra that an external source is required to update the board, which is required to start programming it would be a good idea, that way people don’t get bad surprises.

The card should arrive during the week, I’ll follow the manual SD way to update and will keep you informed

Hi Thomas, these aren’t “rules” as much as highly variable things that we’re trying to eliminate. I personally have never powered my Hydra via anything other than USB, as I don’t have a DP module.

I did connect pin 8 and 10 of the socket 3 then powed up, waited 5 seconds and then removed the wire.
I still don’t see any COM/SERIAL port in the device manager
I don’t understand why the first update failed, it seemed to go pretty well until the reset step.
I hope I’m not with an unusable piece or circuitry now…

EDIT: The device is detected as an Unknown device

Try a different PC, perhaps.

http://www.tinyclr.com/forum/topic?id=9154&page=1#msg91336