Fez Hydra not being detected

Hi all, this is my first post and first experience with .NET Gadgeteer but done a lot of stuff with Netduino.
Believe me I tried everything before sending this post.
The problem is that the board is not recognized as any kind of device by Windows. I tried to update the board using the bridge between MISO and Ground pins, also tried with the SD module but always with no luck. Is there a chance the board is not working ok ?

I posted a video showing the steps I’m doing, any tip ?

Thanks in advance.

Sebastian

Welcome!

Sorry to hear about the issue. You said you have tried everything. Can you please tell us what did you try exactly?

Thanks for the quick reply Architect.
Basically I followed the guide “Firmware Update FEZ Hydra”, using a SD module and also using the wired bridge. A summary of what I did is shown in the video I posted. (1.26 min). FEZ Hydra Update Fail - YouTube
If I connect it to a pc via usb, it should be detected as an unidentified device at least?

Thanks

Welcome to the community…

use a POWERED USB HUB… most likely your NETBOOK doesn’t give enough juice through the USB port…

Here is more things to try:

  • different USB port
  • different USB cable
  • powered USB hub
  • different PC

I’ve tried in all the PCs at the office. Should I need to use a powered USB hub if I’m using a USB Client DP module with the corresponding power supply ?

Not really. What kind of “corresponding power supply” is it? What its’ output numbers on the sticker?

Don’t use both power plug( Jack and USB) at the same time…
only USB trough a Powered USB HUB… try that…

@ Jay Jay -

Having both power sources conected is OK. USB Client DP has power mux chip.

sebarenzi,

I looked at the video that you posted and I noticed that after you used the Pin 8 to Pin 10 grounding method, you reset the board before running the updater. You should not reset the board right away. Once you remove the “bridge”, run the updater. What grounding pin 8 does is prevents the firmware from being read by the processor and so the processor defaults to its bootloader mode. Once you reset the board, the processor will again search the data flash for the firmware.

I hope this helps. Welcome to the community. :slight_smile:

@ Architect
I know it is but i remember it causing issues with the Spider and the TF35 display (causing a white screen) (GUS confirmed it)… so i suggest sticking to USB trough a Powered HUB for the updates…

Ah, I see. Must have missed that discussion. Is that Spider only?

So far only the spider that’s doing this…

my Hydra doesn’t give the white screen when both are plugged in…

sorry for the delay, I was trying all the options you gave me.

  • Only with a powered usb hub did not work
  • With both USB and power supply did not work
  • Also did what Aron suggested, not resetting the board after removing the bridge

Unfortunately none of them worked.

Just a silly question. If I plug in the board to a PC without any drivers, sdk, etc. Should it be detected as an unknown device at least ?. Because this is not happening in any of the 12 machines I tried.

Thanks

Trying to narrow the problem further.

Do you have access to another DP or SP module?

Also, how about a GHI camera module? If so you can plug that into the DP/SP with the ribbon, and then USB in to the computer.

Not right now, but yesterday I ordered a new SP module, should be here in 2 days.

Yes, that is a good way to check SP/DP module!

Ok, but I’m not going to need a camera module.
If after testing the board with the new SP module and does not work should I consider to ask for a replacement ?

That was a suggestion in case you have one.

GHI is very good at taking care of their customers. I am sure you will have a running Hydra one way or another.