Main Site Documentation

FEZ Hydra Failure during firmware update


#1

Hi,

I have just received a FEZ Hydra board and tried to create an application.
I got following errors:

[quote]Create TS.

Loading start at 20175a40, end 201a2d84

Assembly: mscorlib (4.2.0.0) Assembly: Microsoft.SPOT.Native (4.2.0.0) Assembly: Microsoft.SPOT.Hardware (4.2.0.0)
Assembly: Microsoft.SPOT.Graphics (4.2.0.0) Assembly: Microsoft.SPOT.TinyCore (4.2.0.0)
Assembly: Microsoft.SPOT.IO (4.2.0.0) Assembly: System.IO (4.2.0.0) Assembly: Microsoft.SPOT.Hardware.Usb (4.2.0.0)
Assembly: Microsoft.SPOT.Hardware.SerialPort (4.2.0.0) Assembly: Microsoft.SPOT.Touch (4.2.0.0)
Assembly: Microsoft.SPOT.Ink (4.2.0.0) Assembly: Microsoft.SPOT.Hardware.PWM (4.2.0.1)
Assembly: Microsoft.SPOT.Hardware.OneWire (4.2.0.0) Assembly: System.Xml (4.2.0.0)
Assembly: Microsoft.SPOT.Time (4.2.0.0) Assembly: Microsoft.SPOT.Net (4.2.0.0)
Assembly: System (4.2.0.0) Assembly: Microsoft.SPOT.Net.Security (4.2.0.0)
Assembly: System.Net.Security (4.2.0.0) Loading Deployment Assemblies.

Attaching deployed file.

Assembly: Gadgeteer (2.42.0.0) Attaching deployed file.

Assembly: GTM.GHIElectronics.SDCard (1.1.2.0) Attaching deployed file.

Assembly: InternetRadio (1.0.0.0) Attaching deployed file.

Assembly: Gadgeteer.SPI (2.42.0.0) Attaching deployed file.

Assembly: System.Http (4.2.0.0) Attaching deployed file.

Assembly: GHI.OSHW.Hardware (4.2.5.0) ***********************************************************************

  •                                                                 *
    
  • ERROR!!! Firmware version does not match managed code version!!! *

  •                                                                 *
    
  •                                                                 *
    
  • Invalid native checksum: GHI.OSHW.Hardware 0xF75E8662!=0xF0D4135D *

  •                                                                 *
    

Resolving.

Link failure: some assembly references cannot be resolved!!

Assembly: InternetRadio (1.0.0.0) needs assembly ‘GTM.GHIElectronics.Music’ (1.1.3.0)

Assembly: InternetRadio (1.0.0.0) needs assembly ‘GTM.GHIElectronics.UsbClientSP’ (1.1.2.0)

Assembly: InternetRadio (1.0.0.0) needs assembly ‘GHIElectronics.Gadgeteer.FEZHydra’ (1.1.3.0)

Error: a3000000

Waiting for debug commands…

The program ‘[2] Micro Framework application: Managed’ has exited with code 0 (0x0).
[/quote]

So, I tried to update the firmware of the hydra using the “FEZ Config v013” application.
In the middle of the firmware update, the board lost its connection automatically and the update failed.

Now every time since it failed updating the firmware, I get the following error:

Failure - Device is not connected or not responding.

Is there any way to get rid of this problem?

Thanks,
Mazhar


#2

welcome to the forum,

can you tell us what you see in device manager when you reconnect the hydra to the PC? That will help us understand at what point you’re at. You’re going to need to use the manual process too I think, so get the tools ready (SAM-BA etc )


#3

Hi Brett,

Thanks for the reply,

I am attaching the screenshot; I see “Debuggable .Net Micro Framework Device” in the Device Manager window.

Thanks,
Mazhar


#4

So that tells me that you still have the netmf on the device. Can you open MFDeploy and tell us what happens when you select the USB device from the dropdown - specifically if it has a name that appears when you do so?


#5

Please see the screenshot attached.

Thanks again for the quick reply,
Mazhar


#6

follow the manual steps from https://www.ghielectronics.com/docs/125/firmware-update-fez-hydra


#7

Thanks Brett,

I will try updating the firmware with the manual method.

Mazhar.


#8

@ mazmoiz

You may have updated with the Ethernet version of the firmware and not the Non Ethernet version. You will need to potentially attach an ENC28 Ethernet module to Hydra’s socket 3 which will reactivate the Hydra. You can alternately attach to socket 3 a Char Display module, the G or B cable from any of the LCD display modules, or a Music module will also reactivate your Hydra.


#9

Thanks alot Aron, you are Great !! :slight_smile: