FEZ Hydra Ethernet firmware update failed

@ ppatierno - The Fs are normal. We do not have any specific serial numbers for the Hydra and those are just fillers that MFDeploy probably use.

So It seems that I have Ethernet firmware on it but If I go in “Network Configuration” in FEZ Config and click on “Load Ethernet Config”, I receive :

“No response from device”

Is there another problem ? :frowning:

@ ppatierno - No. By default, the Ethernet firmware is always active on the Hydra and Cerb-based boards if you are using the Ethernet firmware. On the Premium boards, Ethernet is dynamic and therefore can have it’s Ethernet information changed.

Only through MFDeploy can you change the TCP/IP information for the Hydra and Cerbs.

@ ppatierno -

  • Can you call Ping it (in connection tab, Ping button)?
  • Is there ENC28 connected? (it should be connected)

@ ppatierno - My apologies. I forgot that you can change the TCP/IP information for non Premium board in FEZ Config. I believe the error may be because you do not have the Ethernet firmware on your device.

@ ppatierno - When you used MFDeploy to install the firmware, did you choose the Ethernet version?

ENC28 is connected.
I can ping the board.
In the Network Configuration I can’t click on Apply Ethernet Config (it is disabled) and If I click on Load Ethernet Config, I receive “No response from device”.


@ ppatierno - If you remove the ENC28 module from the Hydra and reset the board, can you ping the device with a response?

After a reboot It seems to work…I can load and apply network configuration !
A simple application that I have that use socket works !
Thank you very much !!

Now…why a full firmware erase was needed ? Was there a corrupt firmware on the board ?
I’m so curious to understand the reason… :wink:


…and It worked only with MF Deploy…not with FEZ Config !

I am glad that you are able to run networking code on your device.

It is possible that the firmware was corrupt (why it could have been corrupt could be as simple as static). Did you have the ENC28 module on socket 3 the whole time you were having issues with the updating process? The Hydra will not work if the ENC28 module not connected while the Ethernet firmware is present on the board.

I am not sure as to why only MFDeploy worked for you but if ever in doubt, use all available tools.

Thank you very much Aron !
I have another Hydra board and I hope that it will work better ! :wink:
Now I can start to develop on my new Hydra !