Main Site Documentation

FEZ Hydra Ethernet firmware update failed


#1

Hello,
I want to update my FEZ Hydra board with Ethernet firmware using FEZ Config.

I have connected a powered USB hub to my PC and FEZ Hydra to this hub (in this way I have external power supply).
When I try to update with Ethernet firmware I receive the error in the attached image.
What it the problem ?

Paolo.


#2

I tried on 4 different PCs for a total of 11 USB ports !
The result is the same always with USB hub with external power supply.
In this moment I can’t use the board because ethernet is fundamental !

Paolo


#3

Is the Ethernet module connected? To which socket?


#4

Until now I thought that it wasn’t necessary to connect the ethernet module to update !
Now I have connected the ethernet module on socket 3 and tried on 2 different PCs…the result is the same !! :frowning:
I’m always using a USB hub with external power supply.

Paolo.


#5

Enc28 module?


#6

Yes Gus…it’s Enc28 module.


#7

Are you able to deploy the non-Ethernet firmware? Do you have a second Hydra you can try? Do you have any modules connected aside from the ENC28?


#8

I tried only one time with NON Ethernet firmware and it failed.
I haven’t any other module connected.
I will try on the other Hydra I have.


#9

@ ppatierno - Can you try to do a manual update of Hydra following these instructions: https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra


#10

Hi Aron…
but in this way I will update TinyBooter and not TinyCLR with Ethernet firmware.
From FEZ Config it results that TinyBooter and TinyCLR on the board are the latest version but TinyCLR is NON Ethernet.
Why I have to update TinyBooter ?


#11

@ ppatierno - The real point is not to update TinyBooter but to do a complete erasure of the board’s flash memory in case the firmware was corrupted. You could try to put the board into TinyBooter mode to see if you can erase the firmware without a complete erasure/restore. Follow the instructions found here: https://www.ghielectronics.com/docs/39/fez-hydra-developer#360

Focus on these lines:


#12

Hi Aron,
the link you give me now speaks about shorting pin 9 to pin 10 on socket 14.
The previous link https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra speaks about shorting pin 8 to pin 10 on socket 3 or 14.
What is the right connection for starting in TinyBooter mode ?

So your last suggestion is to put the board in TinyBooter mode and then use MF Deploy to erase firmware ? Is it right ?


#13

@ ppatierno - Yes, first try to put the board in TinyBooter mode by shorting pin 9 to pin 10 on socket 14. While shorting these pins you will reset the board.once the board is reset, stop shorting the pins.

If you use MFDeploy you will ping the board and it should report back TinyBooter. FEZ Config should work also to report the boot state of the board.


#14

Excume me Aron…but I want to understand well going deeper.
What is the difference to short pin 9 to pin 14 and pin 8 to pin 14 as described in the links you gave me ?
Is there a difference between shorting pin 9 or pin 8 or there is a mistake on the web site on the two different links ?

Excuse me… :wink:


#15

@ ppatierno - no problem ppatierno. The difference between the two are as followed:

The grounding of pin 9 (shorting pin 9 to pin 10) on Socket 14 is a special pin designated to place the board into TinyBooter mode (only on Hydra) for situations when a program that the user writes may cause your board to lock up and become unresponsive. If this scenario were to take place, there needs to be a way to bypass the system to gain some level of functionality, in this case, the ability to erase a user program and/or even to erase and replace the firmware, should that have become corrupted.

On Socket 3 or 4, the need to ground pin 8 (shorting pin 8 to pin 10) is necessary to bypass the flash microchip on the board to allow the Hydra’s processor to be booted into a mode where it is ready to accept commands to erase the flash chip and to rewrite the TinyBooter to allow the re installation of the firmware.


#16

Ok Aron ! Thanks for your explanation.

Now I’m at office and in 2-3 hours (at home) I will try to apply your suggestion.

So recap :

  1. short pin 9 to pin 10 on socket 14 and press reset;
  2. the board will start in TinyBooter mode;
  3. I erase the firmware using MF Deploy;

After the firmware is erased, can I try to update last Ethernet firmware with FEZ Config ?


#17

@ ppatierno - Yes, you should be able to use FEZ config to apply a new firmware to Hydra if it has been erased prior with MFDeploy.


#18

Ok Aron…I will “update” you very soon ! I hope with good news !

Paolo.


#19

Hi Aron…I shorted pin 9 to pin 10 on socket 14 and with MFDeploy I erased flash (firmware, user data, …).
Now My HYdra starts always in TinyBooter (there isn’t any firmware, TinyCLR) but If I try to use FEZ Config to upload firmware, the result is the same.
Can I try with MFDeploy instead of FEZ Config ?
What is your opinion ?

Paolo.


#20

I executed upload using MFDeploy and it finished without errors !
From MFDeploy If I check for device capabilities, I receive the following message :

Pinging… TinyCLR
HalSystemInfo.halVersion: 4.2.0.0
HalSystemInfo.halVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
HalSystemInfo.oemCode: 255
HalSystemInfo.modelCode: 0
HalSystemInfo.skuCode: 65535
HalSystemInfo.moduleSerialNumber: FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
HalSystemInfo.systemSerialNumber: FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
ClrInfo.clrVersion: 4.2.0.0
ClrInfo.clrVendorInfo: Microsoft Copyright © Microsoft Corporation. All rig
ClrInfo.targetFrameworkVersion: 4.2.0.0
SolutionReleaseInfo.solutionVersion: 4.2.6.1
SolutionReleaseInfo.solutionVendorInfo: Copyright © GHI Electronics, LLC
SoftwareVersion.BuildDate: Oct 17 2013
SoftwareVersion.CompilerVersion: 410713
FloatingPoint: True
SourceLevelDebugging: True
ThreadCreateEx: True
LCD.Width: 320
LCD.Height: 240
LCD.BitsPerPixel: 16
AppDomains: True
ExceptionFilters: True
IncrementalDeployment: True
SoftReboot: True
Profiling: False
ProfilingAllocations: False
ProfilingCalls: False
IsUnknown: False

Are normal all the “F” characters ???

Paolo