FEZ Hydra bricked? (white screen, no reaction)


I’m in a really bad position, I got a FEY Hydra with a T35 display and a SP USB-Client.
I then used the 5 step Updater(Wrong?) and it started to erase sectors on the board
and suddenly failed leaving me with nothing but a white screen. The device is seen
by the PC but only as “unrecognized device”…please tell me that the board isn’t screwed.
Since this is a project for the company I’m doing an internship for its a bad situation I’m in.
After this I found the 7 step updater(probly too late) and tried to erase the flash with the pin method,
since we don’t have a card-reader-module.
I hope someone here can help me out, since I saw in other posts around the forum that this is a great


Do not worry, your device is fine. Where did you get your updater from, what folder? Have you tried to manually update? See wiki please.

Welcome to the community.

All came with the stuff I downloaded from here:

first updater from this folder /GHI .NET Gadgeteer SDK (the one that crashed while erasing)
second updater from this folder /GHI OSH NETMF v4.1 SDK

I checked out the wiki and tried the wire erase on both sockets #3 and #4 but it seems like nothing happens.
I cant deploy anything so the bypass is not possible, we don’t have and won’t need a sd-reader for our project
and the soldering part doesn’t sound good to me(plus we don’t have the equipment here) in terms of my soldering capabilities.

Thank you very much

EDIT: Tried to install drivers manually and W7 finally installed it as ChipworkX Tinybooter Updater Driver (COM3)

What do you see under device manager?
Us hydra connected to a powered hub or directly to the pc?

After the drivers finally worked: ChipworkX Tinybooter Updater Driver (COM3)