FEZ DUINO cannot Deploy 2.0

Hello all,

Just updated VS2019 to clr 2.0 and tried to deploy existing, working app. Output window shows “Deploying incrementally” then I get Error “There was not enough space to totaling 0 bytes to deploy assembly”.

Reinstalled tinyclr, tried it on VS 2017, and reloaded firmware 1 to the board. Still fails.
TinyCLR 2.0 does not install to this board. Says file is corrupted.

Any ideas please?

try to update latest firmware (today released - Production Ready (RTW))
with latest VSIX ,get latest libraries and configuration software all those you can find here


than try it again :slight_smile:

Thanks but no luck. When I try to update firmware it says entering bootloader mode then says the uploaded file is corrupt.
Have latest config tool and VS is up to date and has GHI packages installed (2.0)

Again, it works on OS/1 for the FEZ Duino.

I am guessing you have FEZ T18 and not FEZ Duino. Show us a photo of your board please.

Yes it says T18

so that confirms it isn’t supported with TinyCLR OS 2.0, it must remain on TinyCLR 1.0. No point trying any further, just won’t work (it’s an old processor without suitable security features)

That is FEZ T18 and not FEZ Duino. It has been discontinued but you can still use TinyCLR 1.0.