Main Site Documentation

Fez Config refuse to update Cobra I


#1

Hi All,

after upgrading my cobra 1 to 4.3 I forgot one step - To update the tinybooter first, so I tried to do this afterwords. Although, the cobra 1 boots and reports 4.3.4.0 but the tinybooter in boot mode mentions:

[quote]TinyBooter v4.2.0.0
EMX Build Date:
Jan 13 2013 14:28:03
Copyright GHI Electronics
TinyBooter GHI Version 4.2.8.0
Waiting
[/quote]

Trying to update the tinybooter through fez config gives me always the message:

The Loader cannot be updated if more than one device is connected.
Make sure that only one device is connected and that it is in bootloader
mode.

There IS only one device connected and as can be seen above it is in tinybooter mode. There is one device listed as a Cerb-Family in EMX mode.

The Fez config message comes back all the time and updates do not happen.

Any help would be much appriciated !!!

PS. All cerbuino-bee or cerbuino-net or cerberus updated without problems at all.


#2

Some pics to show some details


#3

@ PiWi -

what does that mean, please?


#4

Once I connect the Cobra 1 it displays the following on the Cobra 1 7" LCD:

And in windows 8.1 64 Bit -> Devices and printers it shows an icon under Unspecified named Cerb-Family.

Once I put the Cobra in Bootloader mode (the 7" LCD turns blank) in the device manager it shows the GHI Bootloader Interface as COM7 but with an exclamation mark (as well in devices and printers as in dev mgr). The device is NOT seen by Fez Config.

Tried to uninstall the Bootloader and re-install the Bootloader only to get the same reaction. The GHI Bootloader is 2.0.0.0. from Feb 20 this year. See pictures for more detail.


#5

@ PiWi - I’ve successfully updated two Cobra 1’s to R2 and R3.


#6

@ jasdev: it is probably something strange with the bootloader, the device reports 4.3.4.0 allright.

Have to check a blinky app for proper workings in vs2012 but I assume that’ll work ok.