Main Site Documentation

FEZ Config - Loader Tiny Booter Not Present On Device


#1

I’ve got a Cerb40 II.

I was having some issues with VS2012 and loading some code, so I decided to load up FEZ Config. I clicked check for update and I’m seeing:

[quote] Loader (TinyBooter) version information:
4.2.6.1 on this computer.
Loader (TinyBooter) Version: Not present on the device.[/quote]

That seemed very odd to me. So I decided to reload the TinyBooter. I jumped the loader pin to 5V, and plugged the usb back in and loaded up STDFU Tester. Ok device recognized in DFU mode.

I followed these steps precisely without any errors:
https://www.ghielectronics.com/docs/55/loader-tinybooter-update-fez-cerberus#2300

Went back into the FEZ Config and here’s the following when I click “Check device for update”:

[quote] Loader (TinyBooter) version information:
4.2.6.1 on this computer.
Loader (TinyBooter) Version: Not present on the device.

Firmware (TinyCLR) version information:
4.2.6.2 on this computer.
Firmware (TinyCLR) Version: Not present on the device.
The device is in Loader mode.
Click on ‘Reboot CLR’ under the Advanced menu to reboot the device.[/quote]

I tried the “Reboot CLR” and it gives me the exact same results as above.

I’ve repeated my steps several times. The Tiny booter doesn’t load onto the device? Any ideas?

Thanks.


#2

@ Gismofx - After re flashing the TinyBooter, does Cerb-Family_Gadgeteer show up under the Device options? What does the output display if you ping the device?


#3

Hi Aron,

Yes, it does say Cerb-Family_Gadgeteer

When I Ping it says

Can’t get any further than that.

Thanks!


#4

@ Gismofx - perhaps try to go to the Firmware Updater Tab and try the updating process anyway.

If that does not work, try to use MFDeploy that Micro Framework provides.


#5

@ Aron I tried that, and should have mentioned that in the original post…

I’ll try with MFDeploy.


#6

When loading firmware.hex with MFDeploy it hangs at Checking Signature phase and then I get an error.


#7

@ Gismofx - Is this the only device that you can try updating with? Do you perhaps have another one with which to try?


#8

@ Aron,

Yes. This is the only one I have. After doing MFdeploy, the device is no longer recognized in FEZ Config…I went back to reloaded the loader with STDFU Tester and now it’s recognized.

Back at square one. Could it be the USB drivers or something related to that? What’s the best way to verify?


#9

@ Gismofx - Im uncertain if it could be the USB Drivers. Here are a couple of more suggestions to try:

Try to use another computer.

If that does not work, try to download the latest SDK (NETMF and Gadgeteer Package 2014 R1) from the Support->NETMF page and see if that would fix the issue. If this SDK has been install previously, try to uninstall it and re install the SDK and see if this will fix the issue.


#10

@ Aron,

Uninstalled, Rebooted, and Reinstalled. Same Results. I will try on another computer, but it was working before all this happened on the same computer.

Why does Fez Config think my device is in “Loader mode”?


#11

Sorry, can you give us more info here? You’re saying that you had been using this Cerb40 before, and had updated the firmware and had been programming it. Then something happened and you could no longer do that. And then you started on this journey you’ve documented here.

Any hints what else happened ? Did you have a failed deployment or anything ?


#12

@ Brett

Yes. It was working just fine up until this morning. I pulled out the Cerb from my box of stuff and went to deploy some code that I’ve deployed before from Visual Studio 2012. Upon deployment the debugger didn’t seem to attach to the device, but nothing looked unusual in the output dialog box. Unfortunately, I didn’t save the output text. I can’t really say what happened. I didn’t have anything hooked up backwards or anything at all. Just the board and the usb cable. So, I felt compelled to dig a little deeper and that’s where my post starts.

Thanks!


#13

how long had it been since you’d used the Cerb? And had you used a different product in the past or had you not used any netmf for a while (shame on you if that’s the case :wink: joking ! )


#14

@ Brett

Haha! …maybe :wink:
I used it no more than a week ago…Surprisingly, I do have another netmf device…netduino 2, but I was having some problems and was really eying the Cerb 40, so I thought I’d try it. I dig the form factor and features and the community seems really great…Some of my issues immediately went away with the Cerb 40, but I’m running into one particular problem, same as my Netduino, which I detailed in another post (still near the top of the forum).

So, I’m jumping between devices but looks like Cerb 40 would end up in my final project. Would love to get to the bottom of this.


#15

I have the same symptoms and have tried the same steps to resolve the issue. Was a resolution ever posted for this issue?


#16

Hi Mike, welcome !

I don’t think there’s actually a recognition that there’s anything systemic here. Might be worth you creating your own topic to help troubleshoot, but I have never seen a situation where after booting into STDFU mode, then correctly deploying the bootloader, has left the processor in a state where the CLR couldn’t then be loaded on. The developers guide has a number of steps that if you don’t follow can result in the bootloader not being applied which might be relevant to your situation https://www.ghielectronics.com/docs/46/fez-cerb-family-developers-guide
Click the Create from Map button
Select the Erase radio button
Click Go
Once finished, click Load DFU File button
Select C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.3 SDK\Firmwares\Cerb Family\Loader.dfu (or relevant).
Click Download radio button
Click Go.
Reboot your board


#17

Here is a video I did on updating the Cerberus v1, not sure I’m going to keep it, but it might help here.