Main Site Documentation

FEZ Cobra II (Eco) installing NETMF and Gadgeteer Package 2013 R2


#1

Hi I have started installing NETMF and Gadgeteer Package 2013 R2 and reach the point of using Tera Term Pro to transfer G120_TinyBooter.GHI. The dialogue shows 2.1% then after a few minutes Tera Term Pro sends BL. The attached file shows the dialogue. I downloaded the package again to correct? any corruption and reinstalled GHI Premium NETMF v4.2 SDK.msi etc but still have the same failure. I have Cobra II with an extension board and a TE35 screen attached. I am using VS2012 with .NET Micro Framework 4.3. Please look at the photo attached. Please advise.


#2

It looks like you are using wrong parameters for the xmodem transfer. Inspect the document carefully. I vaguely remember a radio button to the right saying 1k when you select the file.


#3

Thank you for your reply Andre: I found the legacy updater here: https://www.ghielectronics.com/downloads/firmware/GHI_NETMF_Firmware_Updaters_legacy.zip and ran it with 100% no problem: please see the attached photos.
Andre I now have a fixed white screen (TE35). Do I need to configure it in FEZ Config? How do I get the required settings? Many thanks.

Thank you for your reply njbuch. I did set the 1k setting. Is there another setting?


#4

I took the settings listed in the Developers article for T35 example code. Is this correct for TE35? Photos attached.


#5

When starting the Cobra II the TE35 screen stays white blank. I reset the board and after a “long” pause the “Waiting for debug commands” screen appears. I may have the config incorrect as the first column of characters is half displayed i.e. “V” shows “/”. Have I configured the TE35 correctly?


#6

Many thanks Andre. I am currently working on a Gadgeteer Project. I loaded the project, removed the screen TE35 from the diagram and re-added it. I then closed down VS2012 and opened FEZ Config retrieved the LCD config from the device (see attached). The config of TE35 is slightly different and the letters on the screen are now properly positioned. Thank you for your help.


#7

just a gentle reminder. If you’ve applied a new SDK recently, you need to rip and replace all old references or create a new project and re-add your existing code…the best way to test these things is definitely to use a clean project every time too…


#8

Yes I will start a new project as I have changed the SDK. Thanks Brett. The next step is to download the source from https://gadgeteer.codeplex.com/SourceControl/latest to see if any changes have been made to the WiFi RN171 module.