Main Site Documentation

FEZ Cobra II and Seeed problem


#1

Hi,

I have made a design on work using the EMX module but thought that I wanted to do a private project.
I wanted to play with some of the modules available using gadgetter. I got a FEZ Cobra II NET and upgraded my system to NETMF and Gadgeteer Package 2013 R2.

I tried to make my first project added a couple of the modules I bought but are running into some problems. Adding the lightsensor to socket 4 is no problem but when adding the temperature and Humidity sensor I get the following error:
This module installer was not correctly set up, it does not provide a compatible assembly for .NET Micro Framwork version 4.2
And under errors:
Error 1 The type or namespace name ‘Seeed’ does not exist in the namespace ‘Gadgeteer.Modules’ (are you missing an assembly reference?)
Program.generated.cs 25 35 GadgeteerApp1

This is in the auto-generated file so something is missing from my system. Any tips or ide would be appreciated. Have tried to seek for seeed but cant find any module or referents to that.
-Thomas


#2

Sounds like you are missing an assembly reference. Hard to say without seeing your code.


#3

That is what I thought but I am not able to add the module from the designer (drag it from the toolbox and I get the error. Included an image.

Also include the auto generated code (made the redunderline words bold in the code,(Seeed).


//------------------------------------------------------------------------------
// <auto-generated>
//     This code was generated by a tool.
//     Runtime Version:4.0.30319.18052
//
//     Changes to this file may cause incorrect behavior and will be lost if
//     the code is regenerated.
// </auto-generated>
//------------------------------------------------------------------------------

namespace GadgeteerApp1 {
    using Gadgeteer;
    using GTM = Gadgeteer.Modules;
    
    
    public partial class Program : Gadgeteer.Program {
        
        /// <summary>The LightSensor module using socket 4 of the mainboard.</summary>
        private Gadgeteer.Modules.GHIElectronics.LightSensor lightSensor;
        
        /// <summary>The SerCam module using socket 5 of the mainboard.</summary>
        private Gadgeteer.Modules.GHIElectronics.SerCam serCam;
        
        /// <summary>The TemperatureHumidity module using socket 6 of the mainboard.</summary>
        private Gadgeteer.Modules.[em][stro[/em]ng]Seeed[/b].TemperatureHumidity temperatureHumidity;
        
        /// <summary>This property provides access to the Mainboard API. This is normally not necessary for an end user program.</summary>
        protected new static GHIElectronics.Gadgeteer.FEZCobra_II Mainboard {
            get {
                return ((GHIElectronics.Gadgeteer.FEZCobra_II)(Gadgeteer.Program.Mainboard));
            }
            set {
                Gadgeteer.Program.Mainboard = value;
            }
        }
        
        /// <summary>This method runs automatically when the device is powered, and calls ProgramStarted.</summary>
        public static void Main() {
            // Important to initialize the Mainboard first
            Program.Mainboard = new GHIElectronics.Gadgeteer.FEZCobra_II();
            Program p = new Program();
            p.InitializeModules();
            p.ProgramStarted();
            // Starts Dispatcher
            p.Run();
        }
        
        private void InitializeModules() {
            this.lightSensor = new GTM.GHIElectronics.LightSensor(4);
            this.serCam = new GTM.GHIElectronics.SerCam(5);
            this.temperatureHumidity = new GTM.[em][stro[/em]ng]Seeed[/b].TemperatureHumidity(6);
        }
    }
}


#4

Does it work if you instantiate it manually? You need to add reference to the assembly using “Add Reference” dialog.


#5

No, Thats the problem cant find anything called Seeed or TemperatureHumidity on my system.

And the error I included the picture indicates that there are no support for this module on my system… I start to think that it is not included in the latest release?
Its the same for all modules under the tree Seed in the included picture.
I also ha a moisturesensor and an PulseOximeter I want to try, they all give the same error.


#6

I would try to reinstall SDK.

You should be able to see/add Seeed’s assemblies in the “Add Reference” dialog:


#7

Reinstalling didnt work, had to right click the seed msi package and choose repair that seems to do the trick.

Was able to add a module without any troubles so now on to write some code to test the sensor, tanks for the advice.


#8

No problem! :slight_smile: