Main Site Documentation

Faulty T35 Display Module?


#1

Hi,

I recently received a FEZ Spider Starter Kit and I think the LCD module is faulty. Upon startup it goes white for a few seconds, then goes black for a second or two, and then starts drawing a black line that progressively works its way down the screen before starting again back at the top and working back down the screen.

When running the picture taking sample, I sometimes see a hint of another color like red or blue, but most of the time the line going down the screen is black.

I’ve double checked the connections, run the firmware update that is included with the SDK install, tried other cables, and worked through the display troubleshooting guide found here: http://wiki.tinyclr.com/index.php?title=Gadgeteer_Display. The display troubleshooting program exhibits similar problems (line going down the display, sometimes white, sometimes glimpses of other colors).

Please let me know what else to try / where to go from here.

Thanks!
-Joshua.


#2

Have you tried adding power pack or using powered hub?


#3

Hi Joshua,

I had the same thing happen. I also had the sound of the device being added and disconnected continuously inside windows.

For me it was the lack of power. I plugged it into a powered USB Hub and problem solved.

Jas


#4

Hi Gus and Jas,

Thanks for the quick replies!

Using a 4xAA battery pack or a 9V 0.5A wall wart, I get a white screen and no lines.

What should I try next?

-Joshua.


#5

What’s the proper way to contact GHI about the possibility of replacing my display module? Using an external power supply didn’t fix it. The contact us page says I need to go through the forums for support.

Is there something else I need to try? I just noticed that there’s a new SDK package on the support page. I’m going to give that a try, just in case.

My FEZ Spider starter kit has been sitting idle as most of what I want to do with it requires the display module to work.


#6

have you tried to reload the firmware while on the external power supply?


#7

please send an email to GHI directly with a link to this post and detailed explanation of what you are seeing. We will take care of it.


#8

Thanks for the replies! I’m going to update to the latest SDK and latest firmware using an external power supply. I’ll post back with results.