Main Site Documentation

Failed to upgrade TinyBooter(EMX) from 4.2.0.0 to 4.2.9.0. MFDeploy could not find the EMX name now


#1

Hi Guys,

I updated my EMX board today but failed.
First I entered boot loader mode and erased/flashed new TinyBooter.GHI (use 1K for XMODEM transfer). here is the log:

BL
BL
BL
1.02
BL
Erase all memory! Are you sure?
Erasing…


Done.
BL
1.02
BL
1.02
BL
Start File Transfer
CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
File Transfer Finished Successfully
TinyBooter v4.2.0.0
EMX Build Date: Feb 13 2013 13:27:28
ARM Compiler version 410713
MSdbgV1–¯Ô
ƒ§˜’

After Tera term sent TinyBooter.GHI, the console printed TinyBooter v4.2.0.0. And it did not shows BL. I rebooted the board and MFDeploy.exe could not connect the device anymore.

I re-download GHI Software Package 4.2 again (http://www.ghielectronics.com/download/ghi-software-package-v4.2-02142013) and updated the tinybooter again. But got the same result.

Any idea about this?

Thanks.


#2

Everything looks correct. What do you see under device manager? (after you have TinyBotter loaded)


#3

@ Gus -

Before updating, I can see GHI debugger interface in device manager, but now I could not find it anymore. (I guess that is why MFDeploy.exe could not find USB name).

PS. My OS is Windows 8 (64 bit). Could it be the reason that I could not update tinybooter?

Thanks & Best Regards!
Phoenix


#4

When TinyBooter is loaded, a different USB driver is loaded.


#5

@ Gus -

I see. but the problem is that there is no unknown device shown in device manager. :frowning:


#6

@ Gus -

Here is new update.

I have old boards, they runs MF 3.5. And the board I mentioned above is purchased from you several months ago (we purchased 50 pics in same time, they runs MF 4.2).

I just tried to upgrade tinybooter of an old board to 4.2.9.0, but after flashing the firmware, tera term reported “Bad firmware”. Then I downgraded the tinybooter to 4.1.6.0. I could get debugger interface back on the old board.

I did the same thing on the new board to downgrade tinybooter to 4.1.6.0, GHI debugger interface still could not show. Here is the log message from tera term:

EMX
TinyBooter Mode
Version: 4.1.6.0
Debug: COM1
LCD: 320x240
IP: 0.0.0.0
MAC: 00.00.00.00.00.00
Managed heap size: 1048580
Custom heap size: 0
TinyBooter v4.1.2821.0
EMX Build Date: Jun 30 2011 11:00:00
ARM Compiler version 410561
MSdbgV1z^ü¢a2?

Information about new/old boards:
V command from tera term:
old: 1.10 new: 1.0.2 (version of old is bigger)
H command from tera term:
old: BL new: X11 (the old board doesn’t support H command)


#7

I run Win8 x64 and have done for a while. I have no problem changing my EMX device, so it’s not that…

The “bad firmware” message. I would reinstall the SDK.

If you don’t see an unknown device, it may just be hidden by being collapsed. Can you check that the device actually registers by having sound turned on and the Device Manager open and see it refresh - and see what appears, if anything? You could also proactively try installing the GHI bootloader driver, from the SDK, without a device attached and see if that helps.

One last question, by any chance do you know if your USB port is a USB3 port?


#8

@ Brett -

Hi Brett,

Before I upgraded tinybooter for new one. My laptop did find the debugger interface. After I uploaded tinybooter.GHI with tera term, no new device was found in device manager (I scanned the device manager, and there was no sound after uploading firmware.).

I know the old devices doesn’t support MF 4.2. The new boards are purchased from you in Nov 2012, should them support the latest SDK? I’ll check another board when I get to office today.

By the way, the usb ports on my laptop are not USB3 ports.


#9

I am surprised that there’d not be a device connected (even a device connect failed) noise. To triple check (sorry, I know… sorry :slight_smile: ) I would disconnect the device from the PC, then connect it again with bootloader switches held down, and see if that registers at all.

You ARE talking about an EMX aren’t you? Can you confirm, is this on a custom mainboard that you made? Is there any chance they haven’t been tested before?

EMX supports 4.2, so this is NOT an issue.


#10

@ Brett -
Yes, all devices are on a custom mainboard by us. I reconnect the cables and still could not find devices on PC or get any sound.

I believe the problem is that the new device doesn’t support the latest sdk and tinybooter.ghi. It does be able to communicate with tera term. It doesn’t support 4.1 too. I am trying to restore TinyBooter.GHI to 4.2.0.0 to make the device working. But I could not find SDK 4.2.0.0 from website.

I did the same thing with an old device. After I upgraded tinybooter to 4.2.9.0, I could not find any device or get any sound on PC either, but after I downgraded it to 4.1.6.0. Now I could flash firmware and it works fine with VS2010 now.


#11

ok so actually your problem may be related to the actual GHI driver and the WinUSB change. I don’t know enough to help here, and you should probably reach out direct to GHI tomorrow (or wait for them to come online on a weekday in a few hours)


#12

Do you have a display on your board? What do you see on it?


#13

@ Gus -
the device has no display. Today I tried with another new devices (ordered in Nov 2012), and got same result - I could not upgraded it to 4.2.9.0 or downgrade it to 4.1.6.0. Anyway I am still able to communicate with the devices via tera term.


#14

Have you tried a different PC? It is very strange that you see nothing on device manager!


#15

Now I have the same problem with G120 also not to see dispatcher device firmware update mode.


#16

Same problem? As in you go to device manager and see nothing? Windows may have failed to load the drivers but it should see something.


#17

@ Gus -
Just tested on a Windows 7 machine and got the same result - No device was found in device manager. But the device manager does refresh if I replug the USB cable.


#18

@ andre.m -
Thank you very much. Yes. Now I can find hidden GHI .NET Micro Framework USB Debugging Interface, but it is for worked devices. If I remove them, there is no more USB debugging interface or unknown devices. If I put a worked device to PC, it adds USB debugging interface. Then I remove the device, the USB debugging interface become hidden.


#19

@ Gus -
Is there any way that I could download old versions of GHI SDKs (from 4.2.0.0)?

Thanks!


#20

I think you’re chasing a ghost here.

It’s totally unlikely that an older firmware or tinybooter will change your experience. I still think this is more likely to be a driver error. Have you checked your event logs to see if anything is reported there?

If you really want to go back to something older, go into the downloads link Andre sent but you might be better off with the April 2012 v4.1 SDK in the top level http://www.ghielectronics.com/downloads/NETMF/