Main Site Documentation

Failed to link Assembly: needs assembly 'GTM.Seeed.Relays' (1.4.0.0)


#1

Hello guys,
after updating the Spider to 4.1.8.0 (feb 24 2012) release…

i’ve started a new project added a seedstudio relay module to the spider and it compiles fine but it won’t deploy to the unit… giving the following error:


Failed to link assembly...
Assembly: GadgeteerApp5 (1.0.0.0) needs assembly 'GTM.Seeed.Relays' (1.4.0.0)

the assembly is 1.4.0.0 so i don’t know what VS is looking for? deleted the assembly and reinstall it. marked the assemly as to NOT COPY… still no joy…

any one out there care to try it… You do not have to have the Physical module to just this…

just drag and drop the relay module, connect it, deploy and debug and see if you get the above error.

thanks.
thanks.


#2

ddi you flash also Spider with 4.1.8.0 firmware?


#3

Yes i did.
it shows 4.1.8.0 on the T35 Display…

any other ideas?

thanks.


#4

The missing assembly is for any of the the Seeed modules. It is a separate installer.


#5

i ran the installer for seeed that was included in the FEb Package… it didn’t help.
i even went and grabbed the installer for the relay from Seed site and ran it, which all it did is put the same exact assembly version. again no go…

so what is next?

i mean there has to be an easier way to get these updates done… i’ve wasted a good amount of hours and still no Joy…

i wish GUS or someone could actually tell us what VS2010 is looking for here, and how it compares the versions, and where does it get the info from ? is it from the Solution file, Project File ??? maybe if i knew then i could edit the files manually.

thanks for the help.


#6

I’ve tried it with the exact same SDK and steps you used and it worked. Could you try uninstalling the GHI SDKs, Seeed SDK, and the Gadgeteer Core and reinstall?


#7

As a “best practice” I’ve learned that unistalling GHI SDKs before installing new ones will save a lot of headaches. Installing over (upgrading) SDKs has caused enough issues for me personally that I uninstall/install out of habit now. Since adopting the practice, I have not had any SDK update issues. Why does it make a difference? I don’t know.

This suggestion may or may not solve this particular issue, but it may prompt others to test my theory and/or report similar experiences.

Disclaimer - an astute observer will note that this is not a cause and effect relationship. It just may be that I have gained enough experience to reduce the chance of things going south when updating my boards.


#8

Yep After uninstalling and reinstalling the SDK things got back to normal…

A Suggestion maybe GHI Should force the SDK installer to uninstall all SDK’s before reinstalling them…

thanks.


#9

+1