Erratic servo behavior

i have an TPA81 sensor, which in addition to it’s temperature array sensor, provides the ability control a servo. The sensor is connected to socket 2 (I) on my cerbuino vis-a-vis a breakout board (the sensor is an I2C device and socket2 is the only socket that supports I2C). I’ve written the .netmf code to read the temperature and that works fine. Now i’m trying to get the sensor to control the servo…and there i’m running into some issues.

To rule out any issues related to the servo itself, I first tried the servo connected to to a digital pin on the cerbuino powered by the USB from my pC and that works fine…the servo rotates 0 to 180 degrees.
However, when i connect the sensor to the cerbuino and then try to drive the servo through the sensor, it behaves erratically. The problem is that the servo rotates only 90 in one direction only and in a very inconsistent manner…sometimes very jerky motion, and sometime very long pauses or random pauses.

Is this possibly due to the USB source not being able to provide a stable supply?

The sensor requires 5V.
The servo is a Hitec HS322 HD: and requires 4.8 -6v.

When i check the voltage at the servo when everything is connected (with USB from PC as power), i see about around 4.6v…so i’m thinking maybe its just not enough.
I haven’t been able to try a separate power source because all i have are 9.6v battery packs. i’ll probably pick a 6v up later in the week and give it a try…

If you have any suspicions regarding the issue or any advice, i’d appreciate it if you can share them w/ me.


I don’t suppose you have, or have access to, an oscilloscope?

unfortunately I do not.

earlier today i hooked tried using my 9.6v battery in conjunction with a 5v regulator. I confirmed that the output was stable, but still servo would not move…all i hear is a ticking sound. What’s strange is when the regulator is used, the temperature sensor does not seem to work any longer(readings are all zero). If i then revert to powering the sensor from the gadgeteer socket, the temperature reading then look fine.

which begs the question…can I2C devices be powered by an external source or must they use the gadgeteer socket?
as for the servo…i am about to give up on that…

They should be able to be powered by an external power source as long as the voltage is compatible
and they have a common ground.